Bug 116663 - possible problem with unset local variables
possible problem with unset local variables
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 04:09 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 11:09:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-24 04:09:50 EST
Description of problem:

I just tried to compile Core2 Test1 package xpdf-2.03-1

The compiler said

1.

type1.c(1766): remark #592: variable "c1x0" is used before its value
is set
type1.c(1766): remark #592: variable "c1y0" is used before its value
is set
type1.c(1766): remark #592: variable "c1x1" is used before its value
is set
type1.c(1766): remark #592: variable "c1y1" is used before its value
is set
type1.c(1766): remark #592: variable "c2x0" is used before its value
is set
type1.c(1766): remark #592: variable "c2y0" is used before its value
is set
type1.c(1766): remark #592: variable "c2x1" is used before its value
is set
type1.c(1766): remark #592: variable "c2y1" is used before its value
is set

The source code is

        PickCoords(FALSE); /* Pick original control points */

Do all these local variables need initialisation before first use ?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ngo Than 2004-06-24 11:09:55 EDT
it seems to be fixed in new upstream xpdf-3.00-3

Note You need to log in before you can comment on or make changes to this bug.