Bug 116668 - After install of package, run command not found.
After install of package, run command not found.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 04:50 EST by Alex Wohletz
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-25 04:47:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Wohletz 2004-02-24 04:50:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
After installing the package 'snort-2.1.0' or 'ettercap-0.6.9', .  I
get the error message bash: ettercap: command not/ bash: snort:
command not found. Also, during installation of said programs I get a
NOKEY warning during the installation.  
I tried rpm --import /usr/share/doc/rpm-4.2/RPM-GPG-KEY to solve the
NOKEY problem, but no luck with that either.  
So I installed snort using --nosignature, but that doesn't appear to
work, because the command to run the program is still not
found/understood.
I checked to make sure the program is installed with whereis, man, and
rpm -qi and the package to be installed.
I'm new to Linux, am I missing something stupid? Any help would be
appreciated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -ivh snort-2.1.0-rh90.i386.rpm
2.type 'snort' or whatever command to run program into run or
terminal, get 'bash: snort: command not found
3.
    

Actual Results:  Exactly what is mentioned above.

Expected Results:  The Snort IDS should've started up and the NOKEY
problem should've been resolved.

Additional info:
Comment 1 Jeff Johnson 2004-02-25 04:47:24 EST
NOKEY just means that you don't have the pubkey for that
signature, can be ignored.

The package is unlikely to have been signed with RPM-PGP-KEY,
you will nee to find the pubkey with the fingerprint id
mentioned.

rpm -ql snort will give you list of files that are in the package.
You appear to be missing a path, perhaps /usr/sbin, in your
PATH environment variable.

Note You need to log in before you can comment on or make changes to this bug.