Bug 116713 - LTC10134-Option --tree seems broken
LTC10134-Option --tree seems broken
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-packages (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2004-02-24 11:49 EST by Steve Bonneville
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-11 08:36:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Python traceback of --tree=ftp:// output (1.41 KB, text/plain)
2004-02-24 11:52 EST, Steve Bonneville
no flags Details

  None (edit)
Description Steve Bonneville 2004-02-24 11:49:04 EST
Description of problem:
The --tree option does not work when pointed at a installation tree of
RPM packages.  The installation tree works fine with anaconda for
NFS/FTP/HTTP installs.  

1) Mounted NFS export containing the RedHat directory on /mnt/server1
   Ran 'redhat-config-packages --tree=/mnt/server1'
   Get the error "The path /mnt/server1 does not look like a valid
installation source."

2) Placed RedHat directory on FTP server (server1.example.com) in /pub
   Tried 'redhat-config-packages --tree=ftp://server1.example.com/pub'
   Got Python traceback.  Will attach.

3) Tried --isodir using a directory containing the four ISOs.  Works.

Version-Release number of selected component (if applicable):
Comment 1 Steve Bonneville 2004-02-24 11:52:06 EST
Created attachment 97997 [details]
Python traceback of --tree=ftp:// output
Comment 2 IBM Bug Proxy 2004-08-16 12:53:20 EDT
comments on LTC-10134 IBM side
Hardware Environment:
iSeries Legacy
Software Environment:


Steps to Reproduce:
1.mounted ISOs 
2.cp -a /mnt/isodir/RedHat /target/directory/ 
3.repeated for all 4 cds
4.Tried to run redhat-config-packages -t /target/directory/

Actual Results:
Installation Tree Not Found.
The path /redhat/ does not look like a valid installation source.

Additional Information:
Also tried this with mounting nfs dir from install source server and
ended up 
with same results.  Is there another step to do to make install source
with redhat-config-packages?
Comment 3 Jeremy Katz 2004-08-16 13:01:46 EDT
Do you have the .discinfo file there?
Comment 4 IBM Bug Proxy 2004-08-17 15:46:47 EDT
----- Additional Comments From markwiz@us.ibm.com  2004-08-17 15:44 -------
please verify this with the latest ISO's 8/16. 
Comment 5 IBM Bug Proxy 2004-08-19 11:21:17 EDT
----- Additional Comments From mranweil@us.ibm.com  2004-08-19 11:18 -------
Sorry, Joe's out.  Michelle - can you get that, pls? 
Comment 6 IBM Bug Proxy 2004-08-19 11:56:17 EDT
----- Additional Comments From malward@us.ibm.com  2004-08-19 11:57 -------
yes, I will try to recreate and update this with my results. 
Comment 7 IBM Bug Proxy 2004-08-27 10:58:08 EDT
----- Additional Comments From rayda@us.ibm.com  2004-08-27 10:56 -------
I mounted our nfs install source (that was used to do the installation itself) 
to a partition at /mnt.  I then ran redhat-config-packages -t/mnt and it still 
gives the error message that this doesn't look like a valid install source.

Still broken. 
Comment 8 IBM Bug Proxy 2004-08-27 12:14:18 EDT
----- Additional Comments From pbowen@us.ibm.com  2004-08-27 12:12 -------
Ok we recereated this - we need someone to debug here. Khoa - pls get this 
Comment 9 IBM Bug Proxy 2004-08-31 17:54:28 EDT
----- Additional Comments From mranweil@us.ibm.com  2004-08-31 17:53 -------
Can you give me access to the system where it's failing?  I'll take a look.... 
Comment 10 Bob Johnson 2004-09-01 09:29:54 EDT
IBM , still in need info...
Comment 11 IBM Bug Proxy 2004-09-07 12:40:44 EDT
----- Additional Comments From mranweil@us.ibm.com  2004-09-07 12:40 -------
Can you recreate this on rhel4 at all?  If you can, can you give me access to it? 
Comment 12 IBM Bug Proxy 2004-09-07 15:47:18 EDT
----- Additional Comments From malward@us.ibm.com  2004-09-07 15:46 -------
Mike, I am trying to recreate with RHEL_4 on ilinjck8.  I will let you know 
the results. 
Comment 13 IBM Bug Proxy 2004-09-08 11:10:35 EDT
----- Additional Comments From malward@us.ibm.com  2004-09-08 11:08 -------
I used the RHEL_4/beta isos to install ilinjck8 then mounted the install 
source. I then ran redhat-config-packages -t/mnt/cd  and received an error 
message that the redhat-config-packages command not found. 
Comment 14 IBM Bug Proxy 2004-09-08 16:10:34 EDT
----- Additional Comments From rayda@us.ibm.com  2004-09-08 16:11 -------
I reproduced this with RHEL 3 QU3 GA packages.  I installed w/ nfs and mounted 
the same source at /mnt, exported the DISPLAY, then ran redhat-config-packages -
t/mnt and got the error that said it was not a valid install source.  My guess 
is it will fail equally well with the cd's. 
Comment 15 IBM Bug Proxy 2004-09-08 21:05:45 EDT
----- Additional Comments From mranweil@us.ibm.com  2004-09-08 21:07 -------
The rhel4 version is system-config-packages.  I can't get that to run, it
requires a display (which I exported) but then it does this:
[root@ilinjck8 ~]# system-config-packages
_X11TransSocketINETConnect() can't get address for redsfan8:6003: Temporary
failure in name resolution
Unable to import gtk module.  This may be due to running without
$DISPLAY set.  Exception was:
could not open display
Traceback (most recent call last):
  File "/usr/share/system-config-packages/MainWindow.py", line 11, in ?
NameError: name 'sys' is not defined
[root@ilinjck8 ~]#

This seems like it's basically ltc bug 9341 (rit 41702) in the service family. 
I started to try the workaround there.... 
Comment 16 Jeremy Katz 2004-09-13 14:43:35 EDT
This is fixed up in 1.2.15 which I'm about to build.
Comment 17 IBM Bug Proxy 2004-10-04 13:44:57 EDT
----- Additional Comments From markwiz@us.ibm.com  2004-10-04 13:41 EDT -------
This bug is in Modified state on the Red Hat side. We should see this in U4. 
Comment 20 IBM Bug Proxy 2004-11-08 15:52:28 EST
----- Additional Comments From mlui@us.ibm.com  2004-11-08 15:50 EDT -------
Problem still exists in QU4. 
Comment 21 IBM Bug Proxy 2004-11-08 16:00:53 EST
----- Additional Comments From mranweil@us.ibm.com  2004-11-08 16:01 EDT -------
Ok, it looks like this should be fixed in rhel4 beta2, maybe, but not the rhel3
qu4 beta 2 that we have:

mranweil@redsfan8:/var/file-sharing/redhat/RHEL_4/beta2> find . -name
mranweil@redsfan8:/var/file-sharing/redhat/RHEL_3_QU4/beta2> find . -name

It's not clear to me, but at least we have a version # greater than what Jermey
references on rhel4.... 
Comment 22 IBM Bug Proxy 2004-11-08 16:01:14 EST
----- Additional Comments From mranweil@us.ibm.com  2004-11-08 16:02 EDT -------
Monza - so can you try this on rhel4 beta2?  And is this really a block level
severity bug? 
Comment 23 James Laska 2004-11-08 16:55:36 EST
This bug is being used to track a problem in RHEL3-U3 and RHEL4-Beta2. 
Unfortunately, bugzilla only allows you to file an issue against one product.  I
suggest that if this problem exists in RHEL4, we should file a new bug against
Red Hat Enterprise Linux (nahant).

Moving this issue back to assigned as it appears the fix is not in RHEL3-U4
Comment 24 Jeremy Katz 2004-11-08 17:00:49 EST
... because the fix was agreed to just go into the devel stream
because doing an updated package to fix an error message (on the path
that isn't the normal or recommended) was deemed far more work than
it's worth.
Comment 25 IBM Bug Proxy 2004-11-08 17:32:35 EST
----- Additional Comments From mlui@us.ibm.com  2004-11-08 17:27 EDT -------
Problem exists in RHEL4 beta2 mounting nfs directory as install source.  
Changing severity to high.  Opened a new bug (#12362) for RHEL4 beta2. 
Comment 26 IBM Bug Proxy 2004-11-08 23:05:43 EST
----- Additional Comments From mlui@us.ibm.com  2004-11-08 21:09 EDT -------
Reopening this bug since it is not yet fixed in QU4 beta2.

Khoa/Pamela/Mike, when should the target milestone be? 
Comment 27 James Laska 2004-11-10 15:38:21 EST
As I understand it, this issue is tracking the --tree option for RHEL3.  If this
bug exists in RHEL4, please file a seperate issue.  From comment#25 from
mlui@us.ibm.com it appears that a new LTC bug was filed to track RHEL4.  Has
this been mirrored over to Red Hat Bugzilla yet?
Comment 28 IBM Bug Proxy 2004-11-10 16:05:56 EST
----- Additional Comments From mlui@us.ibm.com  2004-11-10 16:02 EDT -------
James, the bug has been mirrored to RH bugzilla as #138420. 
Comment 29 IBM Bug Proxy 2004-11-10 17:11:07 EST
----- Additional Comments From mlui@us.ibm.com  2004-11-10 17:11 EDT -------
Verified that this bug is fixed. 
Comment 30 James Laska 2004-11-10 17:23:58 EST
mlui@us.ibm.com: To confirm, you are no longer experiencing this problem on
RHEL3?  What is the version of redhat-config-packages tested?  Thanks.
Comment 31 IBM Bug Proxy 2004-11-10 20:17:18 EST
----- Additional Comments From mlui@us.ibm.com  2004-11-10 20:15 EDT -------
James, my name is Monza.  

Yes, the bug is verified to have been fixed in QU4.  
[root@y0121p9 root]# rpm -qa|grep redhat-config-pack
Comment 32 James Laska 2004-11-11 08:36:40 EST
Thanks Monza!  Closing this issue as FIXED CURRENTRELEASE.  Please re-open this
issue if a regression is detected.  Please follow bug#138420 (LTC12362) for
changes to system-config-packages in RHEL4. 

Note You need to log in before you can comment on or make changes to this bug.