Bug 116728 - printtool hangs when attempting to add new queue
Summary: printtool hangs when attempting to add new queue
Status: CLOSED DUPLICATE of bug 113158
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-printer (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-24 18:55 UTC by Paul Sundling
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Sundling 2004-02-24 18:55:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
When starting printtool and then selecting new, it hangs with a
message that says "Loading printer information.  Please wait...". 
When run from the command line, the following error is visible:

Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 537, in
new_button_clicked    self.use_foomatic ()
  File "/usr/share/printconf/util/queueTree.py", line 467, in use_foomatic
    self.conf.foomatic_init_overview ()
  File "/usr/share/printconf/util/printconf_conf.py", line 1554, in
foomatic_init_overview
    root = parser.parse (foo)
  File
"/usr/src/build/288888-x86_64/install/usr/lib64/python2.2/site-packages/_xmlplus/utils/qp_xml.py",
line 134, in parse
xml.parsers.expat.ExpatError: no element found: line 1, column 0


Version-Release number of selected component (if applicable):
redhat-config-printer-gui-0.6.79.2-1

How reproducible:
Always

Steps to Reproduce:
1. /usr/bin/printtool
2. click on "New"
3.
    

Actual Results:  "Loading printer information.  Please wait..." in X
and errors on the command line as in description.

Expected Results:  printtool would allow a new queue to be created for
a printer.

Additional info:

Comment 1 Justin M. Forbes 2004-02-24 19:49:24 UTC

*** This bug has been marked as a duplicate of 113158 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:37 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.