Bug 116764 - arts causes xmms to crash
arts causes xmms to crash
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: arts (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
: 116765 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 18:55 EST by Jim Cornette
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-24 23:06:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2004-02-24 18:55:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
After launching xmms for the first time, xmms needed to be changed to
use alsa sound. I selected the alsa outputs, then tried to play an ogg
file. Xmms outputted the following error within gnome terminal. 

xmms
Unable to connect to UNIX socket /tmp/.esd/socket
Unable to connect to UNIX socket /tmp/.esd/socket
 
Segmentation fault
 
You've probably found a bug in XMMS, please visit
http://bugs.xmms.org and fill out a bug report.
 
Xlib: unexpected async reply (sequence 0x5f4b)!


Version-Release number of selected component (if applicable):
arts-1.2.0-1.5, xmms-1.2.9-5.p

How reproducible:
Always

Steps to Reproduce:
1. Launch xmms for the first time (no .xmms directory and files in $HOME.)
2. Click on play. Note that after file selection, xmms wants a viable
output.
3. select the alsa sound output
4. Try playing an ogg file again.
    

Actual Results:  1. OK (great! This clears up another bug submitted)
2. Normal behavior. Alsa is not set as default output (It should be
defaulted to alsa.)
3. No problem applying alsa output.
4. This crashes xmms in a very short time.

Expected Results:  xmms to launch, output driver already selected for
alsa. Player to output sound in xmms.

Additional info:

To check if xmms was being negatively effected by arts, I removed arts
with the --nodep flag and relaunched xmms. I was able to play an ogg
file normally. I am using the GNOME desktop.

When launching xmms without arts installed, the following output is
displayed in the gnome-terminal.

libartsc.so.0: cannot open shared object file: No such file or directory

xmms will play correctly.

I then reinstalled arts, removed the .xmms directory, relaunched xmms.
after setting output to alsa, selecting ogg, selecting play, xmms
crashed with the above error.

When I relaunched xmms, no files to play were selected, arts was still
selected as the output. I also got a dialog box that said some other
program may be blocking your soundcard.

closing down xmms gives me the below error to the gnome-terminal.

 xmms
Message: artsxmms_open(): Unable to initialize aRts: can't connect to
aRts soundserver
warning: leaving MCOP Dispatcher and still 146 types alive.
Message: artsxmms_open(): Unable to initialize aRts: can't connect to
aRts soundserver

.again, removing arts allows xmms to function. If arts is reinstalled,
it will now not cause xmms to error (unless you remove the xmms
directory and go again.)
Comment 1 Jim Cornette 2004-02-24 19:20:16 EST
An additional comment:
 Xmms is defaulted to use the esound output.

A question:
why is the libartsc.so.0 library accessed for alsa output?
Comment 2 Miloslav Trmac 2004-02-24 21:09:38 EST
*** Bug 116765 has been marked as a duplicate of this bug. ***
Comment 3 Jim Cornette 2004-02-24 23:06:14 EST
bug 116765 was a hit browser after going back, then forward to the
same page.

The solution to the problem is to restart your computer after applying
the updates to alsa and xmms. (at least restart X)

The arts and xmms fixes solved the issue.

Though using the latest kernel does produce the below output in
gnome-terminal upon starting xmms from terminal.

Gdk-WARNING **: shmat failed: error 22 (Invalid argument)

strace shows this error while xmms is running in a loop. xmms still
works though.

gettimeofday({1077680682, 738162}, NULL) = 0
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7,
events=POLLIN}], 3, 0) = 0
gettimeofday({1077680682, 738299}, NULL) = 0
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7,
events=POLLIN}], 3, 0) = 0
gettimeofday({1077680682, 748451}, NULL) = 0
poll([{fd=3, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7,
events=POLLIN}], 3, 0) = 0

Note You need to log in before you can comment on or make changes to this bug.