Bug 116777 - autoconf-213 isn't needed at expect, autoconf >= 2.52 works fine, too.
autoconf-213 isn't needed at expect, autoconf >= 2.52 works fine, too.
Product: Fedora
Classification: Fedora
Component: expect (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Depends On:
  Show dependency treegraph
Reported: 2004-02-24 20:49 EST by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 5.43.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-03-10 16:12:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-02-24 20:49:00 EST
Description of problem:
Well, I tried a rebuild of expect without autoconf-213, I used to
try that autoconf >= 2.52 and it works fine - I got no errors.

Version-Release number of selected component (if applicable):

Actual results & expected results:
Maybe you could test my experiment, too and if it works good in
your eyes, remove please the old autoconf-213 from the spec file :)
Comment 1 Jens Petersen 2004-02-25 05:33:47 EST
Ok, thanks.  Should get into next build.
Comment 2 Jens Petersen 2004-08-05 00:09:26 EDT
Should get fixed in expect-5.42.1-1.
Comment 3 Jens Petersen 2004-08-05 03:58:06 EDT
On second thoughts I had to revert this change, because a slightly
broken configure file is generated, which breaks the build on some

configure: running /bin/sh './configure' --prefix=/usr 
'--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin'
'--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share'
'--includedir=/usr/include' '--libdir=/usr/lib'
'--libexecdir=/usr/libexec' '--localstatedir=/var'
'--sharedstatedir=/usr/com' '--mandir=/usr/share/man'
'--infodir=/usr/share/info' '--with-tcl=/usr/lib' '--with-tk=/usr/lib'
'--enable-shared' '--with-tclinclude=/usr/include/tcl-private'
'CFLAGS=-O2 -g -pipe -march=i386 -mcpu=i686' --cache-file=/dev/null
configure: warning: CFLAGS=-O2 -g -pipe -march=i386 -mcpu=i686:
invalid host type
Comment 4 Jens Petersen 2005-03-07 01:26:24 EST
Thanks, should be fixed in 5.43.0-1.
(cf bug 150369)
Comment 5 Robert Scheck 2005-03-10 16:12:30 EST
5.43.0-1 rebuilt with current autotools is in Rawhide, closing now.

Note You need to log in before you can comment on or make changes to this bug.