Bug 116780 - ldap support in php appears to conflict with mod_auth_ldap when using SSL
ldap support in php appears to conflict with mod_auth_ldap when using SSL
Status: CLOSED DUPLICATE of bug 112470
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-24 21:36 EST by Nathan Ollerenshaw
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Ollerenshaw 2004-02-24 21:36:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.6) Gecko/20040206 Firefox/0.8

Description of problem:
When using php to access a SASL enabled OpenLDAP server, you will find
that PHP won't be able to load the ssl functions, as mod_auth_ldap
loads these before PHP.

However, disabling mod_auth_ldap doesnt seem to fix the problem, so I
am not sure what is going on here.

Version-Release number of selected component (if applicable):
php-ldap-4.3.4-1.1

How reproducible:
Always

Steps to Reproduce:
1. Set up OpenLDAP
2. Enable SASL auth in /etc/openldap/slapd.conf
3. install pypldapadmin or some other php app that supports SASL
connections to OpenLDAP
4. Configure to use SASL.
5. Try to connect

Actual Results:  The application fails to bind with an error message
indicating as such. Apache starts with the following in the error log:


[Tue Feb 24 20:36:17 2004] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Tue Feb 24 20:36:18 2004] [notice] Digest: generating secret for
digest authentication ...
[Tue Feb 24 20:36:18 2004] [notice] Digest: done
PHP Warning:  Function registration failed - duplicate name -
ldap_connect in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_close in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_bind in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_unbind in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_read in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_list in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_search in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_free_result in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_count_entries in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_first_entry in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_next_entry in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_get_entries in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_first_attribute in Unknown on line 
0
PHP Warning:  Function registration failed - duplicate name -
ldap_next_attribute in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_get_attributes in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_get_values in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_get_values_len in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_get_dn in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_explode_dn in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_dn2ufn in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name - ldap_add
in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_delete in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_modify in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_mod_add in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_mod_replace in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_mod_del in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_errno in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_err2str in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_error in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_compare in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_sort in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_get_option in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_set_option in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_parse_result in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_first_reference in Unknown on line 
0
PHP Warning:  Function registration failed - duplicate name -
ldap_next_reference in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_parse_reference in Unknown on line 
0
PHP Warning:  Function registration failed - duplicate name -
ldap_rename in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_start_tls in Unknown on line 0
PHP Warning:  Function registration failed - duplicate name -
ldap_set_rebind_proc in Unknown on line 
0
PHP Warning:  ldap:  Unable to register functions, unable to load in
Unknown on line 0
[Tue Feb 24 20:36:19 2004] [notice] Apache/2.0.48 (Fedora) configured
-- resuming normal operations


Expected Results:  Should be able to use simple binding for
mod_auth_ldap and SASL for php-ldap.

Additional info:
Comment 1 Joe Orton 2004-02-25 04:39:54 EST
Was this install an upgrade from RH9?  There is a bug which causes
this kind of error on upgrades; if you have any:

extension= 

lines left in /etc/php.ini, remove them, as the modules are now loaded
by /etc/php.d/*.ini.
Comment 2 Joe Orton 2005-01-13 05:20:51 EST

*** This bug has been marked as a duplicate of 112470 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.