Bug 116823 - bison crashes with missing ending semicolon
bison crashes with missing ending semicolon
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: bison (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
:
Depends On: 127101
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-25 10:43 EST by Göran Uddeborg
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 22:33:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2004-02-25 10:43:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
Running bison on this three line input file

   %%
   some_identifier:
   %%

results in a segmentation violation.

Version-Release number of selected component (if applicable):
bison-1.875-4

How reproducible:
Always

Steps to Reproduce:
1.bison ah.y    

Actual Results:  bash-2.05b$ bison ah.y
Segmentation fault

Expected Results:  A correct (if pretty uninteresting) ah.c parser.

Additional info:

This does not happen on i386.  It happens on x86_64.

I'm aware omitting the final semicolon from rules is considered
obsolecent.  For a while bison warned about it, but that seems to be
gone again.  In any case, it should not crash.
Comment 1 Roland McGrath 2004-06-25 04:48:31 EDT
This is fixed by upgrading to version 1.875c, which will be in the
next erratum.
Comment 2 Jay Turner 2004-09-01 22:33:19 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2004-267.html

Note You need to log in before you can comment on or make changes to this bug.