Bug 116829 - thread-test fails on ia64
Summary: thread-test fails on ia64
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glib2   
(Show other bugs)
Version: 1.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-25 16:32 UTC by Mark McLoughlin
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-13 17:15:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark McLoughlin 2004-02-25 16:32:43 UTC
on ia64 thread-test segfaults in the g_thread_exit() in
test_g_static_rec_mutex_thread().

Backtrace looks like this:

#0  uw_update_reg_address (context=0x2000000000e0a890,
fs=0x2000000000e09f90, regno=UNW_REG_RP) at
../../gcc/config/ia64/unwind-ia64.c:1860
#1  0x2000000000e36850 in uw_update_context
(context=0x2000000000e0a890, fs=0x2000000000e09f90) at
../../gcc/config/ia64/unwind-ia64.c:2042
#2  0x2000000000e37740 in _Unwind_ForcedUnwind_Phase2
(exc=0x2000000000e0bcf0, context=0x2000000000e0a890) at unwind.inc:140
#3  0x2000000000e379b0 in _Unwind_ForcedUnwind
(exc=0x2000000000e0bcf0, stop=0x200000000003c918,
stop_argument=0x2000000000e0ae10)
    at unwind.inc:202
#4  0x200000000008a950 in _Unwind_ForcedUnwind
(exc=0x2000000000e0bcf0, stop=0x200000000003c918,
stop_argument=0x2000000000e0ae10)
    at unwind-forcedunwind.c:85
#5  0x2000000000086dc0 in __pthread_unwind (buf=0x2000000000e0ae10) at
unwind.c:130
#6  0x200000000007e210 in __pthread_exit (value=0x0) at pthreadP.h:148
#7  0x2000000000044070 in g_thread_exit_posix_impl () at
gthread-posix.c:375
#8  0x2000000000e36850 in uw_update_context
(context=0x4000000000002220, fs=0xc00000000000038e) at
../../gcc/config/ia64/unwind-ia64.c:2042
#9  0x2000000000e36850 in uw_update_context
(context=0xc00000000000028c, fs=0x6000000000005bb0) at
../../gcc/config/ia64/unwind-ia64.c:2042

Comment 1 Mark McLoughlin 2004-02-25 16:37:38 UTC
This is with:

glib-2.3.3-1
gcc-3.3.3-2
glibc-2.3.3-10

Comment 2 Mark McLoughlin 2004-03-02 10:02:38 UTC
with glib-2.3.5 test-thread is failing on s390 too. Haven't
investigated this at all

Comment 3 Matthias Clasen 2004-05-13 17:15:22 UTC
The glib-2.4.0-1 currently in FC2 seems to have been built fine on
ia64 and s390, so the thread-test issue must have been fixed.


Note You need to log in before you can comment on or make changes to this bug.