Bug 11688 - Missing gifs
Summary: Missing gifs
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: faq (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Ed Bailey
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-26 14:43 UTC by starback
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-22 15:17:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description starback 2000-05-26 14:43:17 UTC
The html in "faq" refers to some missing gifs.  One of them has
the wrong name, and the other are totally missing.

In the following fix I also removed the creation of /usr/doc/FAQ/ps
since the postscript files are explicitly ignored by the spec file anyway.

(Warning:  I have never edited rpm spec files before, but it seemed
straightforward enough...)

$ diff -c faq.spec.ORIG faq.spec
*** faq.spec.ORIG	Thu Feb  3 18:39:44 2000
--- faq.spec	Fri May 26 16:29:59 2000
***************
*** 1,7 ****
  Summary: Frequently Asked Questions (FAQ) about Linux.
  Name: faq
  Version: 6.2
! Release: 1
  Source: ftp://sunsite.unc.edu/pub/Linux/docs/faqs.tar.gz
  Copyright: distributable
  Group: Documentation
--- 1,7 ----
  Summary: Frequently Asked Questions (FAQ) about Linux.
  Name: faq
  Version: 6.2
! Release: 2
  Source: ftp://sunsite.unc.edu/pub/Linux/docs/faqs.tar.gz
  Copyright: distributable
  Group: Documentation
***************
*** 26,32 ****

  %install
  rm -rf $RPM_BUILD_ROOT
! mkdir -p $RPM_BUILD_ROOT/usr/doc/FAQ/{txt,html,ps}
  for faq in *FAQ ; do
    if [ -d $faq ] ; then
      [ -f $faq/$faq ] && cp $faq/$faq $RPM_BUILD_ROOT/usr/doc/FAQ/txt
--- 26,32 ----

  %install
  rm -rf $RPM_BUILD_ROOT
! mkdir -p $RPM_BUILD_ROOT/usr/doc/FAQ/{txt,html}
  for faq in *FAQ ; do
    if [ -d $faq ] ; then
      [ -f $faq/$faq ] && cp $faq/$faq $RPM_BUILD_ROOT/usr/doc/FAQ/txt
***************
*** 36,41 ****
--- 36,47 ----
      cp $faq $RPM_BUILD_ROOT/usr/doc/FAQ/txt
    fi
  done
+ # This is how the file is referred to in the html:
+ mv $RPM_BUILD_ROOT/usr/doc/FAQ/html/Mailbox.gif
$RPM_BUILD_ROOT/usr/doc/FAQ/html/MailBox.gif
+ # Top-level gifs used by html pages:
+ for gif in *.gif ; do
+   cp $gif $RPM_BUILD_ROOT/usr/doc/FAQ/html
+ done

  %files
  %defattr(644,root,root,755)
***************
*** 47,52 ****
--- 53,63 ----
  rm -rf $RPM_BUILD_ROOT

  %changelog
+ * Fri May 26 2000 Per Starback <starback@ling.uu.se>
+ - include top-level gifs used by html pages.
+ - don't create ps directory since the postscript files are ignored
anyway.
+ - rename bogus Mailbox.gif.
+
  * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
  - bring it up to date
  - fix description

Comment 1 Trond Eivind Glomsrxd 2000-06-22 15:16:59 UTC
Isn't this part of the doc cd now?

Comment 2 Ed Bailey 2000-07-18 15:52:52 UTC
This will be addressed in the next version of Red Hat Linux.  Thanks for your
feedback!


Note You need to log in before you can comment on or make changes to this bug.