Bug 116902 - Bugs in less with iso254 code
Bugs in less with iso254 code
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: less (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-26 01:20 EST by Mark Nudelman
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 11:41:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Email describing first bug (552 bytes, text/plain)
2004-02-26 01:24 EST, Mark Nudelman
no flags Details
Email describing first bug (552 bytes, text/plain)
2004-02-26 01:24 EST, Mark Nudelman
no flags Details
Email describing second bug (971 bytes, text/plain)
2004-02-26 01:24 EST, Mark Nudelman
no flags Details
Email describing third bug (1.20 KB, text/plain)
2004-02-26 01:25 EST, Mark Nudelman
no flags Details

  None (edit)
Description Mark Nudelman 2004-02-26 01:20:28 EST
Description of problem:
Hi. I am the author of the "less" program.  I have recently received 
several bug reports about problems in less on RH9 which after 
investigation, turned out to be bugs in the iso254 patch (for non-UTF-
8 Japanese support) which you have applied to less in your 
distribution.  All the bug reporters were satisfied by simply 
reverting to the standard version of less without the iso254 patch.  
I recommend that you somehow make the standard version of less, 
without the iso254 patch, available to your customers, since it is 
more stable without the patch.

Version-Release number of selected component (if applicable):


How reproducible:
See attachments

Steps to Reproduce:
  
Actual results:


Expected results:


Additional info:
Comment 1 Mark Nudelman 2004-02-26 01:24:18 EST
Created attachment 98062 [details]
Email describing first bug
Comment 2 Mark Nudelman 2004-02-26 01:24:30 EST
Created attachment 98063 [details]
Email describing first bug
Comment 3 Mark Nudelman 2004-02-26 01:24:50 EST
Created attachment 98064 [details]
Email describing second bug
Comment 4 Mark Nudelman 2004-02-26 01:25:08 EST
Created attachment 98065 [details]
Email describing third bug
Comment 5 Karsten Hopp 2004-02-26 05:35:38 EST
I absolutely agree with you about the 'quality' of the iso254 patch. 
I've already dropped it from the less version in the Fedora Core 2 
as it isn't maintained anymore and tended to break things. 
Unfortunately I can't drop that patch from the RH9 version and 
release an erratum as japanese customers are still using it. 
Dropping the non-UTF8 support in a new Fedora Cora release is 
easier.  
Bugzilla #115079 already brought up some concerns about this and I  
advised them to use lv if they can't switch to UTF-8. 
 
Please send all bug reporters which are using Red Hat's less version 
to bugzilla.redhat.com, I'll try to sort things out and forward real 
(non Red Hat) bugs to you. We (I) broke it and you shouldn't have to 
cope with that. 
 
Comment 6 Karsten Hopp 2004-03-02 11:41:40 EST
I've revised my decision about the FC1 update and built the new  
version in updates/testing. It'll be moved to updates if there's 
no regression except the non-UTF8 japanes support, which I don't 
expect. 

Note You need to log in before you can comment on or make changes to this bug.