Bug 116904 - httx doesn't run with acl
Summary: httx doesn't run with acl
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: im-sdk
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Yu Shao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-26 07:56 UTC by Akira TAGOH
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-02-26 09:57:53 UTC


Attachments (Terms of Use)

Description Akira TAGOH 2004-02-26 07:56:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.4.1)
Gecko/20031114

Description of problem:
Since httx is owned by htt user, it doesn't work with default acl for
xserver, because httx has a sticky bit and it's going to run as htt user.
I'm not sure, but does httx really need a sticky bit?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run /usr/lib/im/httx on the terminal
2.
3.
    

Actual Results:  Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
                                                                     
                                                       
Error: Can't open display: :0.0


Expected Results:  it should runs normally

Additional info:

Comment 1 Akira TAGOH 2004-02-26 08:26:55 UTC
basically httx is ran manually or in /etc/X11/xinit/xinitrc.d/xinput
(in the future). in that case it's no privilege already. I don't think
httx and htt_xbe also needs to run as the special user.

Comment 2 Akira TAGOH 2004-02-26 09:57:53 UTC
Fixed in 11.4-18


Note You need to log in before you can comment on or make changes to this bug.