This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 116921 - pppd[10238]: ioctl(PPPIOCSASYNCMAP): Inappropriate ioctl for device(25)
pppd[10238]: ioctl(PPPIOCSASYNCMAP): Inappropriate ioctl for device(25)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ppp (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks: 114875 116727
  Show dependency treegraph
 
Reported: 2004-02-26 09:24 EST by Uwe Beck
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 07:11:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reconnect messages during adsl line was down at provider (12.18 KB, application/x-tar)
2004-02-27 09:44 EST, Uwe Beck
no flags Details
Sysreport adsl01 (583.09 KB, application/x-bzip2)
2004-03-01 08:41 EST, Uwe Beck
no flags Details
A patch which might fix the problem (1.49 KB, patch)
2004-04-02 09:22 EST, Bernd Schmidt
no flags Details | Diff

  None (edit)
Description Uwe Beck 2004-02-26 09:24:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4) Gecko/20030922

Description of problem:
If you use adsl the pppoe and pppd daemon must work together.


Sometime, if /sbin/adsl-connect is reconnect the connection (break
after 24 hours) the pppd is crash with the following messages:

Feb 19 22:41:11 adsl01 pppoe[10239]: Sent PADT
Feb 19 22:41:11 adsl01 pppd[10238]: ioctl(PPPIOCSASYNCMAP):
Inappropriate ioctl for device(25)
Feb 19 22:41:11 adsl01 pppd[10238]: tcflush failed: Input/output error
Feb 19 22:41:11 adsl01 pppd[10238]: Couldn't release PPP unit: Invalid
argument
Feb 19 22:41:11 adsl01 pppd[10238]: Exit.

Next crash:

Feb 25 16:56:42 adsl01 pppoe[4808]: Sent PADT
Feb 25 16:56:42 adsl01 pppd[4807]: ioctl(PPPIOCSASYNCMAP):
Inappropriate ioctl for device(25)
Feb 25 16:56:42 adsl01 pppd[4807]: tcflush failed: Input/output error
Feb 25 16:56:42 adsl01 pppd[4807]: Exit.

This is bad because the ADSL does not works then.
This is not the only problem of pppd at RHEL3.
For more informations over the ADSL problems look at bug #114875 and
my next bugentry.

The crash at reconnect is not every day. Sometime it works ten days
without the crash and then the crash was after 48 hours.


Version-Release number of selected component (if applicable):
ppp-2.4.1-14

How reproducible:
Sometimes

Steps to Reproduce:
1.use adsl with the reconnect after break option
2.wait for reconnect after 24 hours
3.
    

Actual Results:  pppd does not work stabil

Expected Results:  should work stabil

Additional info:
Comment 1 Uwe Beck 2004-02-27 09:44:34 EST
Created attachment 98100 [details]
reconnect messages during adsl line was down at provider

messages from pppd reconnect during adsl line was down at provider
Comment 2 Uwe Beck 2004-03-01 08:41:14 EST
Created attachment 98156 [details]
Sysreport adsl01
Comment 3 Uwe Beck 2004-03-28 15:30:28 EST
There are different versions for ppp in RHEL3.

# strings lib/modules/2.4.21-9.0.1.EL/kernel/drivers/net/ppp_generic.o
| grep version
Kernelmodules are "PPP generic driver version 2.4.2"

The RPM ppp which contains the pppd is version 2.4.1.
# rpm -qa ppp
ppp-2.4.1-14
You see it also in the SRPM.

I build a new ppp RPM based on ppp version 2.4.2 self.

I do not see error messages in /var/log/messages. pppd works correct
since 14 days.

Comment 4 Bernd Schmidt 2004-04-02 09:22:28 EST
Created attachment 99072 [details]
A patch which might fix the problem

ppp-2.4.2 allows error returns of ENOTTY in some places where ppp-2.4.1 dies
with a call to fatal().  This patch changes ppp-2.4.1 to allow ENOTTY there
too.  It also fixes a crash in option parsing.

I cannot test this patch unfortunately due to lack of the necessary hardware.
Comment 7 Uwe Beck 2004-07-11 17:45:40 EDT
First results for test rp-pppoe-3.5-4.1.i386.rpm and
ppp-2.4.1-14.1.i386.rpm together are:

1. Dial on Demand
- works now, the option idle=yes do not longer comes from rp-pppoe
- this mistake was the reason for pppd-crash without a message you can
see the invalid option (I found this with my own ppp-2.4.2 rpm)
 
2. use adsl with the reconnect after break option:
- in my first tests with own simulation the reconnet the pppd works
correct
- also the last two reconnets after 24 hours were without errors

At this time I have only my own firewall-script and start/stop squid 
in ip-up.local and ip-down.local activ. Squid has no traffic and also
my VPN-IPSec is not activ. Both I will include tomorrow to see in the
next two weeks if the pppd-2.4.1 works really correct like ppp-2.4.2 now.

Uwe
Comment 8 Uwe Beck 2004-07-24 16:07:14 EDT
Block for Bug #114875 and #116727 not longer needed. I have no access
to Bug #116727 but I think Bug #116927 is the correct number.

For the reported mistakes is the pppd the reason. The fixes in 
rp-pppoe-3.5-4.1.i386.rpm are o.k.. 

Uwe
Comment 9 Uwe Beck 2004-07-24 21:05:06 EDT
The ppp-2.4.1-14.1.i386.rpm do not fix the problem.
You can get detailed information from RHEL hotline. Look for
issue-tracker issue 35179.

Uwe
Comment 10 Jay Turner 2004-08-17 20:37:07 EDT
Pushing back to assigned, as reporter still appears to be experiencing
issues.
Comment 11 Thomas Woerner 2004-08-19 11:17:46 EDT
Ok, what exactly is now working and what is not?
Comment 13 Uwe Beck 2004-08-22 16:03:34 EDT
I start a new test with ppp-2.4.1-14.1.i386.rpm yesterday. It is on a
productiv machine!

It is correct, the last report in issue-tracker issue 35179 was a
contretemps. It is not normal, that during the if-up.local script the
ADSL line breaks again.

But the same if-up.local and if-down.local scripts never abort short
with my own ppp-2.4.2 rpm. I have only seen the problem with ppp-2.4.1
rpm from RHEL. Correct, bevor the fix. If I have the same breaks again
now, I can only change to my own ppp-2.4.2 rpm!?

Uwe
Comment 14 Thomas Woerner 2004-09-16 06:15:13 EDT
Is "ioctl(PPPIOCSASYNCMAP): Inappropriate ioctl for device(25)" fixed
for you now?
Comment 15 Uwe Beck 2004-09-16 09:00:25 EDT
No problem since 2004-08-22. Only the U3 kernel update interrupt the
long time test.

Uwe

Comment 16 Thomas Woerner 2004-10-08 07:11:40 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.