Bug 116984 - cpio: Bad Magic - during install
cpio: Bad Magic - during install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-26 21:50 EST by Jason Arnold
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 15:05:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Arnold 2004-02-26 21:50:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
I am running fedora core 1 for i686 on my AMD64 3000+.  I received CDs of Fedora Core AMD64 Test 1 from linuxinstall.org.  Upon starting graphical installation (and after the media check which the CD passes) the system hangs for a minute and then says:

error 2 reading header: cpio: Bad magic

in the middle of the blue screen.  Then it goes ahead and says it's loading anaconda.  Then I get:

exec of anaconda failed: Exec format errorinstall exited abnormally

Yes it prints out 'errorinstall' all as one word like that.  Then it prepares my machine for reboot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Put CD in drive
2. Reboot / boot from CD
3. press <enter> for graphical install
4. continue past media check

Actual Results:  I received the errors described above.

Expected Results:  Anaconda should have run.

Additional info:
Comment 1 Jeremy Katz 2004-04-15 01:04:45 EDT
Did the CDs pass the mediacheck? 
Comment 2 David Juran 2004-05-24 07:37:14 EDT
I get the same error with the i386 version of the FC2 release. And
yes, the CD passes a mediacheck in the same CD drive.
Comment 3 Mario Ganz 2004-06-09 04:36:36 EDT
I get this error as well and i am trying to install FC2 i386. and the
cd did pass the check!
Comment 4 Mario Ganz 2004-06-09 04:40:10 EDT
and by the way..i use a ricoh cd-rw drive for installation because the
cd drive cannot deal with the cd during start up an will not react
anymore.
Comment 5 David Juran 2005-02-16 10:09:06 EST
The problem popped up again this time with FC3. The same message about "cpio:
Bad magic" but this time the installation got a little bit further. When the
installer got to looking for old installations to upgrade it didn't find my FC2
installation but just prompted me for the various install alternatives. Does
this sound like the same issue or should I file a new one? Otherwise, could
someone please reopen this  bug?
Comment 6 Bob McTasney 2005-06-25 18:52:44 EDT
(In reply to comment #2)
> I get the same error with the i386 version of the FC2 release. And
> yes, the CD passes a mediacheck in the same CD drive.

I also have the same error while doing the i386 installation of FC4.  CD passes
the test.  Also the ISO from which the CD was made passed the sha1sum test.

Note You need to log in before you can comment on or make changes to this bug.