Bug 117002 - build requirement missing from isdn4k-utils
Summary: build requirement missing from isdn4k-utils
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: isdn4k-utils   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-27 09:21 UTC by Bernd Kischnick
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 19:39:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernd Kischnick 2004-02-27 09:21:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; de-de) AppleWebKit/124 (KHTML, like Gecko) Safari/125

Description of problem:
isdn4k-utils needs a BuildRequires: libpcap

Version-Release number of selected component (if applicable):
3.2-5.p1

How reproducible:
Always

Steps to Reproduce:
1. rpm -e libpcap
2. rpmbuild --rebuild isdn4k-utils-3.2-5.p1.src.rpm

    

Actual Results:  Build fails because include file net/bpf.h not found

Expected Results:  binary RPM should be built

Additional info:

Comment 1 Bernd Kischnick 2004-02-27 09:51:20 UTC
I'm sorry, the package version I specified is actually from Fedora.
isdn4k-utils-3.1-76 from RedHat Enterprise 3 is clean.

Resolving to NOTABUG

Comment 2 Bernd Kischnick 2004-02-27 10:12:32 UTC
I'm sorry *again* (you're going to hate me!) -
I just noticed that you are also handling Fedora (great!).

So I'm reopening the bug and try to change the Product specification to Fedora.

Thanks for your patience :-)

Additionally, I checked the Fedora developement package 3.2-13.p1: there, the 
BuildRequirement is also still needed and missing.

Comment 3 Ngo Than 2004-02-27 19:39:13 UTC
no, it's not needed to have buildrequires on libpcap in this version,
isdn4k-utils now uses own libpcap


Note You need to log in before you can comment on or make changes to this bug.