Bug 117037 - Esound spec file needs alsa Requires/BuildRequires
Esound spec file needs alsa Requires/BuildRequires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-27 12:10 EST by Dams
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-13 22:51:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2004-02-27 12:10:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.4.1)
Gecko/20031114 Galeon/1.3.13

Description of problem:
esound seems to be now linked against alsa library (libasound) but the
specfile doesnt reflect this change.

[root@pizza ~]# rpm -qR esound|grep -i asound
libasound.so.2
libasound.so.2(ALSA_0.9)
libasound.so.2(ALSA_0.9.0rc4)
[root@pizza /usr/src/redhat/SPECS]# grep -i alsa esound.spec|wc -l
0

1. There should be a "BuildRequires: alsa-lib-devel" in the specfile
2. Devel package should explicitly "Requires:alsa-lib-devel"

3. And, nothing to do with alsa but, devel package should
"Requires: esound = %{epoch}:%{version}-%{release}" not only
"epoch:version". Static libraries (which are included into devel
package) may not be the same between 2 releases of the same
epoch-versioned package.


Version-Release number of selected component (if applicable):
esound(1:0.2.32-3).i386

How reproducible: Always. Every day.
Comment 1 Aleksey Nogin 2004-03-04 17:05:44 EST
triage->easyfix
Comment 2 Dams 2004-03-31 13:24:51 EST
Ping ?
Comment 3 Warren Togami 2004-04-13 22:51:32 EDT
should be in rawhide soon
please inform me of any other reports that you know that are easy fixes

Note You need to log in before you can comment on or make changes to this bug.