Bug 1170518 - host with bond causing Conflict DHCP records
Summary: host with bond causing Conflict DHCP records
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: foreman-proxy
Version: Foreman (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ga
: Installer
Assignee: Mike Burns
QA Contact: Asaf Hirshberg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-04 08:49 UTC by Asaf Hirshberg
Modified: 2015-02-09 15:16 UTC (History)
8 users (show)

Fixed In Version: foreman-proxy-1.6.0.30-5.el7ost
Doc Type: Bug Fix
Doc Text:
Bonded interfaces on hosts caused conflicts in DHCP records, which led to errors when assigning hosts to deployment roles. This fix corrects the DHCP conflicts and now no errors occur when adding hosts with bonded interfaces to deployment roles.
Clone Of:
Environment:
Last Closed: 2015-02-09 15:16:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
dhcp leases (11.03 KB, text/plain)
2014-12-04 08:49 UTC, Asaf Hirshberg
no flags Details
/var/log/messages (422.39 KB, text/plain)
2014-12-09 14:58 UTC, Asaf Hirshberg
no flags Details
latest dhcp leases (6.54 KB, text/plain)
2014-12-09 15:01 UTC, Asaf Hirshberg
no flags Details
more info of the setup (5.93 KB, text/plain)
2014-12-09 15:01 UTC, Asaf Hirshberg
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0156 0 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2015-02-09 20:13:39 UTC

Description Asaf Hirshberg 2014-12-04 08:49:10 UTC
Created attachment 964482 [details]
dhcp leases

Description of problem:
I have tried to deploy ha-neutron deployment on bare-metal while one host configured with bond(the bond nics aren't on the provisioning network). when i tried to assign the host to their role i got the following error on the host with the bond:

Unassigned hosts:
    mac441ea1733d43
        Conflict DHCP records -44:1e:a1:73:3d:43/192.168.0.6 already exists

Version-Release number of selected component (if applicable):
openstack-foreman-installer-2.0.32-1.el6ost.noarch
ruby193-rubygem-open4-1.3.0-9.el6sat.noarch
openstack-puppet-modules-2014.1.1-1.el6ost.noarch

How reproducible:
3/3

Steps to Reproduce:
1. create a bond from 2 nics on one host
2. enter all the host to provisioning state.
3.create a deployment and assign them their roles.

Actual results:
error of dupliacte DHCP records

Expected results:
no error should be shwon 

Additional info:

Comment 4 Asaf Hirshberg 2014-12-07 13:00:08 UTC
Me and Ofer configured one server (puma05) with bond mode 4 (LACP), and one server (puma04)  with bond mode1. When I tried to assign the roles to each node  I got an error on the server with the LACP and on the server with mode 1
I didn't got any errors and  I manage to assign him as a controller. So probably the LACP is causing the duplicate error.

Comment 6 Asaf Hirshberg 2014-12-09 12:16:49 UTC
Tried this setup now with the latest poodle on rhel-7 (bare-metal machines).
got those errors again: 

Unassigned hosts:

    mac441ea1733d43
        Conflict DHCP records -44:1e:a1:73:3d:43/192.168.0.6 already exists
    mac441ea1733991
        Conflict DHCP records -44:1e:a1:73:39:91/192.168.0.7 already exists

and the package was already installed on the Foreman host.


more info:

rhel-osp-installer-0.5.1-1.el7ost.noarch
openstack-puppet-modules-2014.2.6-1.el7ost.noarch
openstack-foreman-installer-3.0.5-1.el7ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el7ost.noarch
rhel-osp-installer-client-0.5.1-1.el7ost.noarch

Comment 7 Asaf Hirshberg 2014-12-09 14:58:21 UTC
Created attachment 966304 [details]
/var/log/messages

Comment 8 Asaf Hirshberg 2014-12-09 15:01:06 UTC
Created attachment 966316 [details]
latest dhcp leases

Comment 9 Asaf Hirshberg 2014-12-09 15:01:49 UTC
Created attachment 966317 [details]
more info of the setup

Comment 12 Asaf Hirshberg 2014-12-15 15:11:14 UTC
useed latest repos and got those errors again:
Unassigned hosts:

    mac441ea1733991
        Conflict DHCP records -44:1e:a1:73:39:91/192.168.0.6 already exists
    mac441ea1733d43
        Conflict DHCP records -44:1e:a1:73:3d:43/192.168.0.7 already exists

Comment 13 Lukas Zapletal 2014-12-16 12:52:39 UTC
Can you explain to me what is your hardware setup? I see two MAC addresses, I suppose both belong to two hosts as primary provisioning NICs. Can you confirm please?

Comment 14 Asaf Hirshberg 2014-12-16 15:38:55 UTC
my setup is: 3 bare-metal controllers.(one with bond mode 5 lacp, one with bond mode 1 and the last without bond), one compute.

i can assign only the compute and the controller without the bond.

Comment 17 Asaf Hirshberg 2015-01-13 13:02:06 UTC
Verified.

foreman-installer-1.6.0-0.2.RC1.el7ost.noarch
rhel-osp-installer-client-0.5.4-1.el7ost.noarch
openstack-foreman-installer-3.0.8-1.el7ost.noarch
rhel-osp-installer-0.5.4-1.el7ost.noarch

Comment 18 Asaf Hirshberg 2015-01-13 13:08:26 UTC
Verified.

foreman-installer-1.6.0-0.2.RC1.el7ost.noarch
rhel-osp-installer-client-0.5.4-1.el7ost.noarch
openstack-foreman-installer-3.0.8-1.el7ost.noarch
rhel-osp-installer-0.5.4-1.el7ost.noarch

Comment 20 errata-xmlrpc 2015-02-09 15:16:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0156.html


Note You need to log in before you can comment on or make changes to this bug.