Bug 117052 - squid didn't rotate its logs when "-k rotate" is execute
squid didn't rotate its logs when "-k rotate" is execute
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: squid (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-27 14:35 EST by Roger Pena-Escobio
Modified: 2014-08-31 19:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 14:45:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roger Pena-Escobio 2004-02-27 14:35:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux; , en_US.UTF-8, en_US, en, es)

Description of problem:
when you try to rotate the squid's logs using "squid -k rotate", it say its rotating the logs but never do it.
my cache is very busy and the access logs can be 500 MB at the end of the day but the size never was a problem to rotate the logs.
now, when upgrate to RHEL i get suprise that the logs wasn't rotate at all, even is it say in cache.log that it do it.

from the cache.log when "squid -k rotate" :
2004/02/27 13:59:14| storeDirWriteCleanLogs: Starting...
2004/02/27 13:59:14|     65536 entries written so far.
2004/02/27 13:59:14|    131072 entries written so far.
2004/02/27 13:59:14|    196608 entries written so far.
2004/02/27 13:59:14|    262144 entries written so far.
2004/02/27 13:59:14|    327680 entries written so far.
2004/02/27 13:59:15|    393216 entries written so far.
2004/02/27 13:59:15|    458752 entries written so far.
2004/02/27 13:59:15|    524288 entries written so far.
2004/02/27 13:59:16|    589824 entries written so far.
2004/02/27 13:59:16|   Finished.  Wrote 635190 entries.
2004/02/27 13:59:16|   Took 1.4 seconds (445445.7 entries/sec).
2004/02/27 13:59:16| logfileRotate: /var/log/squid/access.log
2004/02/27 13:59:16| helperOpenServers: Starting 5 'ncsa_auth' processes



Version-Release number of selected component (if applicable):
squid-2.5.STABLE3-3.3E

How reproducible:
Didn't try

Steps to Reproduce:
1.
2.
3.
    

Additional info:
Comment 1 Roger Pena-Escobio 2004-02-27 14:48:56 EST
sorry i didn't notice that the default value for logfile_rotate was 
changed to 0 and that was the reason of the changed behaivor, i'm 
very upset about enter a bug without 5 times. 

Note You need to log in before you can comment on or make changes to this bug.