Bug 117081 - rpm.headerLoad call causes segfault
rpm.headerLoad call causes segfault
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-28 00:09 EST by Sean Kasun
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-29 17:47:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Kasun 2004-02-28 00:09:42 EST
Description of problem:

When Yum calls rpm.headerLoad to verify downloaded headers, it segfaults.

rpm-python 4.3-0.14 is responsible for the segfault.

How reproducible:

Every time.

Steps to Reproduce:
1. Install rpm-python 4.3-0.14
2. yum list updates.

  
Actual results:

seg fault the first time it checks a header

Expected results:

continuing to check headers

Additional info:

Downgrading to rpm-python-4.3-0.9.1 fixes the problem, so the problem
lies squarely in rpm-python-4.3-0.14
Comment 1 Jeff Johnson 2004-02-28 11:10:22 EST
segfaults in rpmlib are invariably because of bad data is the general
rule.

otherwise, try -0.16, if segfault persists, then attach the
hdr here. short *.py reproducer will expedite fix.
Comment 2 Sean Kasun 2004-02-28 15:55:36 EST
Upgrading to -0.16 fixes it.  After messing around with it, it seems
that it was caused by rpm-python's dependances. rpm-python -0.14
doesn't require rpm -0.14.  So when yum updated, it upgraded
rpm-python from -0.9 to -0.14 before upgrading rpm.  The result was
that it segfaulted right afterwards, leaving rpm at -0.9.
Comment 3 Jeff Johnson 2004-02-29 17:47:24 EST
rpm-python deliberately does not depend on explcit release of
rpm.

Note You need to log in before you can comment on or make changes to this bug.