Bug 117087 - Metacity does not focus on any window after switching desktops
Metacity does not focus on any window after switching desktops
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-28 05:05 EST by Peter Backlund
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 16:45:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Backlund 2004-02-28 05:05:05 EST
Description of problem:
Sometimes, Metacity does not focus any window at all after switching
desktops. It's very hard to find the exact conditions, but it happens
quite frequently (several times per hour at least).  This is with 8
desktops, switching desktops using keyboard, and with click to focus.  

Version-Release number of selected component (if applicable):
metacity-2.7.0-1

How reproducible:
Sometimes

Steps to Reproduce:
1. Switch desktop using keys in click-to-focus mode.
2. 
3.
  
Actual results:
Sometimes, when switching to even a desktop with one single maximized
window, the window isn't focused. Also happens with several smaller
windows.  

Expected results:
One window should be focused.

Additional info:
Ususally some part of the panel, like a launcher, gets focus.
Comment 1 Havoc Pennington 2004-05-25 16:45:42 EDT
Seems to be upstream a few times over (unclear if these are all exact
duplicates):

http://bugzilla.gnome.org/show_bug.cgi?id=133120
http://bugzilla.gnome.org/show_bug.cgi?id=135810
http://bugzilla.gnome.org/show_bug.cgi?id=131582

Note You need to log in before you can comment on or make changes to this bug.