Bug 117095 - (IDE SCSI)Some tape drives fail without the ide-scsi kernel module
Summary: (IDE SCSI)Some tape drives fail without the ide-scsi kernel module
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-28 14:07 UTC by Willem Riede
Modified: 2015-01-04 22:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 06:38:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix ide-scsi error handling, also in -mm (12.02 KB, patch)
2004-02-28 14:21 UTC, Willem Riede
no flags Details | Diff
Patch to make ide-scsi attach more selective (889 bytes, patch)
2004-02-28 14:27 UTC, Willem Riede
no flags Details | Diff

Description Willem Riede 2004-02-28 14:07:03 UTC
Description of problem:
The ide-scsi module is not compiled and distributed which makes it
hard to use tape drives that do not work (properly) with ide-tape,
such as the OnStream DI-30, with Fedora Core going forward.

Version-Release number of selected component (if applicable):
2.6.3-1.*

How reproducible:
modprobe ide-scsi fails

Steps to Reproduce:
1. install fedora core test (1.90)
2. as root, run "modprobe ide-scsi"
3.
  
Actual results:
FATAL: Module ide_scsi not found.

Expected results:
quiet success

Additional info:
As I wrote in
http://marc.theaimsgroup.com/?l=linux-kernel&m=107246268217888&w=2 I
need ide-scsi to survive. Why? I maintain osst, a driver for OnStream
tape drives, which need special handling. These drives exist in SCSI,
ATAPI, USB and IEEE1394 versions.

One high-level driver, osst, handles all of them, and that's how it
should be, right? For ATAPI, it relies on ide-scsi.

(Yes, ide-tape contained code for the ATAPI version, the DI-30, but
that code is old and has serveral known problems - and has been removed).

But, you object, ide-scsi is buggy. Well, I claim to have fixed that,
the patch is in -mm. But, you object, I don't want cd-recorders to use
ide-scsi. Well, I submitted a patch that makes ide-scsi only attach to
drives it is told to attach to, and not grab ATAPI drives by default:
http://marc.theaimsgroup.com/?l=linux-kernel&m=107628037518550&w=2

So, can we please include ide-scsi.ko in the next test release? At
least to see if it behaves better now?

Comment 1 Willem Riede 2004-02-28 14:21:38 UTC
Created attachment 98118 [details]
Patch to fix ide-scsi error handling, also in -mm

Comment 2 Willem Riede 2004-02-28 14:27:44 UTC
Created attachment 98119 [details]
Patch to make ide-scsi attach more selective

With this patch, ide-scsi will _only_ attach to drives that are specified with
the hdX=ide-scsi parameter to the ide subsystem.

Comment 3 Sahil Verma 2004-03-16 19:56:47 UTC
118406 is a dupe.

Comment 4 Willem Riede 2004-03-21 21:20:11 UTC
Comment on attachment 98118 [details]
Patch to fix ide-scsi error handling, also in -mm

Attached patch to fix ide-scsi error handling obsolete as of 2.6.5-rc2 since
Linus has incorporated an improved version of this patch in the mainstream
kernel. This should remove any lingering concerns about re-enabling the
ide-scsi module in future kernel builds.

Comment 5 Warren Togami 2004-04-19 03:37:44 UTC
* Tue Apr 13 2004 Arjan van de Ven <arjanv@redhat.com>               
                                                                     
                                       
- 2.6.5-mc4
- reenable sg driver for scsi tape changers and such

I am not sure if this is related, but does the 326 kernel help the
situation at all?

Comment 6 Willem Riede 2004-04-20 14:53:05 UTC
No, the 326 kernel does not help, since the ide-scsi module is still
not compiled:

[root@fallguy root]# grep BLK_DEV_IDESCSI
/usr/src/linux-2.6.5-1.326/configs/*
/usr/src/linux-2.6.5-1.326/configs/kernel-2.6.5-i586.config:#
CONFIG_BLK_DEV_IDESCSI is not set
/usr/src/linux-2.6.5-1.326/configs/kernel-2.6.5-i586-smp.config:#
CONFIG_BLK_DEV_IDESCSI is not set
/usr/src/linux-2.6.5-1.326/configs/kernel-2.6.5-i686.config:#
CONFIG_BLK_DEV_IDESCSI is not set
/usr/src/linux-2.6.5-1.326/configs/kernel-2.6.5-i686-smp.config:#
CONFIG_BLK_DEV_IDESCSI is not set


Comment 7 Dave Jones 2005-02-24 06:07:18 UTC
should be fixed these days ? confirm ?

Comment 8 Willem Riede 2005-02-26 14:29:20 UTC
yes it is - has been fixed for some time. please feel free to close this bug.


Note You need to log in before you can comment on or make changes to this bug.