Bug 117097 - wrong number of parameters in function calls
wrong number of parameters in function calls
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-28 09:26 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 11:18:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-28 09:26:28 EST
Description of problem:

I just tried to compile Core2 Test1 package texinfo-4.6-1

The compiler said

1.

infomap.c(161): warning #140: too many arguments in function call

The source code is

          ks = find_function_keyseq (map, i, rootmap, NULL);

but, earlier in the same file

static FUNCTION_KEYSEQ *
find_function_keyseq (map, c, rootmap)
  Keymap map;
  int c;
  Keymap rootmap;
{

Four parameters supplied, only three accepted. Suggest delete trailing
NULL on call.

2.

cmds.c(978): warning #165: too few arguments in function call
cmds.c(982): warning #165: too few arguments in function call

Broken source code is
void
cm_w (arg, start, end)
     int arg, start, end;
{
  if (arg == START)
    non_splitting_words++;
  else
    non_splitting_words--;
}

Suggest dropping start & end, since they are not used.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2004-03-02 11:18:22 EST
Point 2 is incorrect I think.

Why not report these kind of cosmetic things upstream, unless there is
really a detrimental symptom?

Note You need to log in before you can comment on or make changes to this bug.