Bug 117101 - system-config-soundcard spews errors and dies with an X BadDrawable
Summary: system-config-soundcard spews errors and dies with an X BadDrawable
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-28 14:44 UTC by Alan Cox
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 19:36:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2004-02-28 14:44:14 UTC
When I run system-config-soundcard it (as with many apps) moans
"DESKTOP_STARTUP_ID contains invalid UTF-8", but starts up. It then prints
FATAL: Module snd_cs46xx is in use.        (True enough)
FATAL: Error running remove command for snd_cs46xx       
/usr/share/system-config-soundcard/soundcardBackend.py (setVolume)
errors trying to execve something (but I have no missing dependancies
reported)
On exit the program then prints

Gdk-Error **: The program 'system-config-soundcard.py' received an X
Window System error. This probably reflects a bug in the program
The error was 'BadDrawable ('invalid Pixmap or Window parameter')

Comment 1 Alan Cox 2004-02-28 14:45:07 UTC
Version 1.2.4-1 sorry.


Comment 2 Bill Nottingham 2004-03-02 05:25:27 UTC
The exec error is fixed in 1.2.5-1.

Comment 3 Brent Fox 2004-03-11 19:36:04 UTC
This should be fixed in system-config-soundcard-1.2.7-3 in Rawhide. 
There was a missing dependency on alsa-utils, which provides
/usr/bin/amixer.  


Note You need to log in before you can comment on or make changes to this bug.