Bug 117102 - at not running scheduled tasks
at not running scheduled tasks
Status: CLOSED DUPLICATE of bug 109587
Product: Fedora
Classification: Fedora
Component: at (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-28 10:25 EST by Sergio Pascual
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Pascual 2004-02-28 10:25:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040124 Galeon/1.3.13

Description of problem:
Tasks scheduled with at are not done. 
Instead, a file named "2"
appears in the working directory.
The mail with the output of the scheduled task is send, but the content
of the mail is compose of error messages described below

Version-Release number of selected component (if applicable):
at-3.1.8-46.1

How reproducible:
Always

Steps to Reproduce:
1. Run a progran inside at:
prompt$ at now
at> ls
at> Crtl-D

Actual Results:  A file named 2 appears in the working directory. to
see the contente of the file I make
prompt$ cat 2
Execution directory inaccessible
prompt$

A mail is sent to me, the content of the mail is:

USER=hare: Command not found.
export: Permission denied.
LOGNAME=hare: Command not found.
export:Permission denied.
HOME=/home/hare: Command not found.
export: Permission denied.
PATH=/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:.:
Command not found.
export: Permission denied.
VENDOR=intel: Command not found.
export: Permission denied.
OSTYPE=linux: Command not found.
export: Permission denied.
MACHTYPE=i386: Command not found.
export: Permission denied.

And follows with more enviroment variables


Expected Results:  A mail is send to me with the output of the ls
program in the present working directory

Additional info:

In the version of at shiped with redhat 9, a meesage appeared
before the at prompt: 
"warning: commands will be executed using (in order) a) $SHELL b)
login shell c) /bin/sh"

This message has disappeared in the present version
Comment 1 Jens Petersen 2004-02-29 20:28:54 EST
Are you using tcsh or csh?
Comment 2 Sergio Pascual 2004-03-01 09:44:32 EST
I'm using tcsh. I have checked that "at" works if your login shell is
bash (that is to say, the shell in /etc/passwd)
Comment 3 Jens Petersen 2004-03-01 20:26:37 EST
Please update to the at in FC devel (aka rawhide).

*** This bug has been marked as a duplicate of 109587 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:01:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.