Bug 117121 - php startup gives: imap.so: undefined symbol: krb5_kt_close
php startup gives: imap.so: undefined symbol: krb5_kt_close
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-28 18:52 EST by Tom Blumer
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 19:48:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Blumer 2004-02-28 18:52:50 EST
Starting from a new Redhat 9 system with all rpms up to date against 
redhat.com using up2date.
redhat 9 apache 2.0.40 php 4.2.2

yum update php (against FC1 core and updates)
updates the following (with no errors/warnings):
[update: php 4.3.4-1.1.i386]
I will install/upgrade these to satisfy the dependencies:
[deps: mod_python 3.0.4-0.1.i386]
[deps: compat-db 4.0.14-2.i386]
[deps: apr 0.9.4-2.i386]
[deps: php-mysql 4.3.4-1.1.i386]
[deps: php-ldap 4.3.4-1.1.i386]
[deps: mod_ssl 1:2.0.48-1.2.i386]
[deps: php-pgsql 4.3.4-1.1.i386]
[deps: apr-util 0.9.4-2.i386]
[deps: mod_perl 1.99_09-10.i386]
[deps: httpd 2.0.48-1.2.i386]
[deps: aspell-en 0.51-6.i386]
[deps: aspell 12:0.50.3-16.i386]
[deps: db4 4.1.25-14.i386]
[deps: php-imap 4.3.4-1.1.i386]
Is this ok [y/N]: y

Then running php gives:

# php -v
PHP Warning:  Unknown(): Unable to load dynamic 
library '/usr/lib/php4/imap.so' - /usr/lib/php4/imap.so: undefined 
symbol: krb5_kt_close in Unknown on line 0
PHP 4.3.4 (cgi) (built: Nov 10 2003 10:36:06)

This indicates that krb5 should probably be updated

yum update krb5-libs

# but that gives this error
# package pine needs libcom_err.so.3
# this is same as my earlier conclusion with rpm tool - that 
upgrading krb5-libs is the right thing to do,
# but that it (strangely) wants to give us an earlier libcom_err.so.2 
when we already have libcom_err.so.3 installed from the orig RH9

httpd -v gives:
httpd: relocation error: /usr/lib/libapr-0.so.0: symbol sys_siglist, 
version GLIBC_2.3.3 not defined in file libc.so.6 with link time 
reference

Any workarounds?
Apache and php will not work after updating an RH9 system to latest 
apache and php from FC1 core and updates.
Comment 1 J. Ross 2004-04-29 18:13:17 EDT
Same problem
Comment 2 Nalin Dahyabhai 2004-08-23 19:48:10 EDT
Pine is preventing krb5-libs from being updated, and php-imap needs
the newer version of the library.  Please update pine to a version
built against FC1 or later (for example, from
ftp://people.redhat.com/mharris/pine/) and re-try.

Note You need to log in before you can comment on or make changes to this bug.