Bug 117127 - Question 9 too complicated?
Summary: Question 9 too complicated?
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Academy
Classification: Retired
Component: RHA030 Curriculum   
(Show other bugs)
Version: 2.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bowe Strickland
QA Contact: Bowe Strickland
URL: https://academy.redhat.com/courses/rh...
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-29 04:37 UTC by Johnathan Kupferer
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 14:32:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Johnathan Kupferer 2004-02-29 04:37:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Workbook 2. Filesystem Basics
Chapter 4. Managing Directories
Questions: #9

IMHO, question 9 "Which of the following commands would copy the
website directory, and all of its subdirectories except
website/media/photos?" is a little too advanced.  Refering to the help
or man page on 'cp' will reveal that none of the specified options
will work.  The problem is further digging will reveal that the
requested task simply cannot be done with the tools the students have
learned so far.  The best solution I see to this problem is to use
'rsync' or a shell script.  It doesn't feel right to tease the
students with a task they can't perform yet.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
n/a
    

Additional info:

Comment 1 Bowe Strickland 2004-03-10 14:32:49 UTC
intent of question was to show
   1) some things can't be done with cp
   2) command line switches can be examined w/ --help, etc.., and 
      the two specified (-d, -x) have nothing to do with the quesiton.

"None of the Above"  seems a clear answer... 

(intent is student's have reference material availabe during 
workbook questions.  agreed, this would not be fair on a test.)

will track student performance on question, and consider change in
upcoming relese.



Note You need to log in before you can comment on or make changes to this bug.