Bug 117146 - Radeon 9200 DRI kills video output (XFree86-4.3.0-45 to -60)
Radeon 9200 DRI kills video output (XFree86-4.3.0-45 to -60)
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-02-29 06:33 EST by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-02-29 15:30:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg-before.txt (11.86 KB, text/plain)
2004-02-29 06:35 EST, Warren Togami
no flags Details
dmesg-after.txt (12.20 KB, text/plain)
2004-02-29 06:35 EST, Warren Togami
no flags Details
dmesg.diff (666 bytes, text/plain)
2004-02-29 06:36 EST, Warren Togami
no flags Details
XFree86.0.log.before.txt (46.45 KB, text/plain)
2004-02-29 06:37 EST, Warren Togami
no flags Details
XFree86.0.log.after.txt (46.01 KB, text/plain)
2004-02-29 06:38 EST, Warren Togami
no flags Details
XFree86.0.log.diff (4.91 KB, text/plain)
2004-02-29 06:38 EST, Warren Togami
no flags Details

  None (edit)
Description Warren Togami 2004-02-29 06:33:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040221 Firefox/0.8

Description of problem:
Hardware: Asus K8V Athlon64 3200+
          "Built by" ATI Radeon 9200

XFree86-4.3.0-42 and -44 works with pcigart mode due to the old broken
AGP vs PCI detection.  -45, -46, -50, -51, -55, and -60 all cause
video output to completely die when DRI is enabled.  Network still
operates so I am able to login remotely to see what happened.  Logs
are attached below.

Tested kernels:
Seemingly equivalent behavior between the three kernels, so this is
probably not a kernel issue.
Comment 1 Warren Togami 2004-02-29 06:35:02 EST
Created attachment 98131 [details]
Comment 2 Warren Togami 2004-02-29 06:35:53 EST
Created attachment 98132 [details]
Comment 3 Warren Togami 2004-02-29 06:36:48 EST
Created attachment 98133 [details]
Comment 4 Warren Togami 2004-02-29 06:37:29 EST
Created attachment 98134 [details]
Comment 5 Warren Togami 2004-02-29 06:38:18 EST
Created attachment 98135 [details]
Comment 6 Warren Togami 2004-02-29 06:38:44 EST
Created attachment 98136 [details]
Comment 7 Mike A. Harris 2004-02-29 10:10:09 EST
It seems to me that your machine only worked before probably
because AGP detection was broken, so it fell back to pcigart,
which just magically happened to work on this board (pcigart
mode usually doesn't work).

I don't believe this is a regression however.  It's just a problem
that was always there, but never showed up before due to AGP
detection being broken.  If you install any of the previous
releases that worked, and can force it to use AGP (possibly
with 'Option "ForcePciMode" "no"' (untested), you'll probably
see the DRI problem occurs even on the older releses also.

Some additional datapoints:
Nothing has changed in the radeon driver nor generic AGP code which
would create a new problem all of a sudden since the builds that
worked for you with pcigart mode.

The AGP detection code is passive, all it does is look at some
flags in PCI configuration space and set a variable which the
driver uses to determine which codepaths to use.

The most likely culprit for this problem I believe is incomplete
or buggy kernel support for AGP in the agpgart driver for this

Alternatively, it is possible that the AGPmode being used could
be instable.  You might want to try changing the AGP mode in the
BIOS, and then setting the AGPmode option in the config file so
that it matches what is set in the BIOS.  Note that AGP 8x mode
is unsupported.

Does changing the AGPmode help?  If not, you can get the old
behaviour back by using:

    Option "ForcePCIMode"

Comment 8 Warren Togami 2004-02-29 15:30:08 EST
You were right... forced AGP 4x mode made it work.

Note You need to log in before you can comment on or make changes to this bug.