Bug 117179 - aic7xxx / aic79xx drivers have highmem IO disabled
Summary: aic7xxx / aic79xx drivers have highmem IO disabled
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jim Paradis
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-01 10:06 UTC by Martin Wilck
Modified: 2013-08-06 01:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 21:30:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Wilck 2004-03-01 10:06:16 UTC
Description of problem:
The aic7xxx and aic79xx drivers have high memory IO disabled (the
can_dma_32/single_sg_ok flags are unset in the SCSI driver template
structure). This is because the driver sources check for the
CONFIG_HIGHIO macro which, in the AS2.1 kernels, is persent in the
kernel .config, but not set in include/linux/autoconf.h. 

This will lead to performance losses in systems wirth large memory.

Version-Release number of selected component (if applicable):
2.4.9-e.xy up to 2.4.9-e.38

How reproducible:
always

Steps to Reproduce:
1.Install RHAS2.1 on system with aic7xxx or aic79xx controller and
>1GB memory.
2. Use "new" driver (aic7xxx 6.x.y) for aix7xxx. 
3. Do I/O.
  
Actual results:
System uses bounce buffers.

Expected results:
System doesn't need bounce buffers.

Additional info:
I came a cross this problem accidentally by comparing the methods how
different driver sources check for the presence of the can_dma_32
field in the SCSI host template.

Comment 1 Jim Paradis 2005-12-05 21:30:06 UTC
This issue is outside the scope of the current support status for RHEL2.1.  No
fix is planned.





Note You need to log in before you can comment on or make changes to this bug.