Bug 117182 - Array overrun in iostat
Array overrun in iostat
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sysstat (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Charlie Bennett
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-01 06:11 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-18 20:45:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-03-01 06:11:31 EST
Description of problem:

I just tried to compile Core2 Test1 package sysstat-5.0.0-0.6

The compiler said

1.

iostat.c(425): warning #175: subscript out of range

The source code is

         st_iodev_tmp[3]->dk_drive_rblk = v_tmp[3];

but, earlier is

   unsigned int v_tmp[3], v_major, v_index;

v_tmp[ 3] doesn't exist. I'm not sure what the fix is for this.

2.

iostat.c(436): warning #175: subscript out of range
iostat.c(447): warning #175: subscript out of range

Duplicates.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Alan Cox 2004-06-16 12:59:39 EDT
Confirmed
Comment 2 Alan Cox 2004-06-16 13:50:28 EDT
Fixed - waiting permission from ccb to commit
Comment 3 Alan Cox 2004-06-18 20:45:47 EDT
Merged into CVS, in FC2 updates testing due to other bugs, will end up
in next release

Note You need to log in before you can comment on or make changes to this bug.