Bug 117196 - Cannot find images
Cannot find images
Status: CLOSED NOTABUG
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Daniel Berrange
http://youth.aplaws.org.uk/ccm/conten...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-01 10:05 EST by James Kearns
Modified: 2007-04-18 13:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-03 14:25:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Kearns 2004-03-01 10:05:53 EST
Description of problem:
Some images are not appearing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. In the back end, go to Content center> Content section: content> 
Transport and Streets> Traffic in Camden> Content item: Images (en)
2. Go to Authoring steps: Image, then Select an existing image
3.
  
Actual results:
Four pages of images.

Expected results:
The same result we get on http://camden.aplaws.org.uk/content/admin/
which is
Ten pages of images including, for example, the following images:
ChargingZone%20Map%20DetailMini.jpg	100 x 78	image/jpeg
ChargingZoneMapCamdenStreets.jpg	800 x 624	image/jpeg
Cntl-Lndn-Congestion-Map-A5.gif		795 x 600	image/gif
Cntl-Lndn-Congestion-Map-tiny.gif	149 x 112	image/gif
Congestioncharge_%20c_%20logo.jpg	70 x 69		image/jpeg
	


Additional info:
First noticed a problem when I looked at Content center> Content 
section: content> Transport and Streets> Traffic in Camden> Content 
item: Congestion charging (en). On http://camden.aplaws.org.uk this 
article displays images but on http://youth.aplaws.org.uk/ the images 
are not available.

Arturo wondered if unpublished images had not been migrated, however 
the last one listed above (Congestioncharge_%20c_%20logo.jpg) was 
published on the old site.
Comment 1 Daniel Berrange 2004-03-02 07:06:52 EST
See also last comments in bug 117260. This looks like it was because
the images were referenced with <img> tags in the HTML rather than
using the proper image  authoring step.
Comment 2 Daniel Berrange 2004-03-02 08:22:53 EST
I'v examined the articles you detailed above & they do indeed contain
<IMG> tags in the body text of the article - hence CMS has no
knowledge of the image in question being part of the Article & thus
they were not migrated. The added problem with referencing these
images inline with <img> tags is that CMS will not correctly publish
the images when the item is published & there will be no DB integrity
checks to ensure the image isn't being used before deletion. Since CMS
didn't know these images were being used, they were not included in
the content migration process & so will need to be uploaded fresh. You
will also need to edit all the articles referencing them to take
account of the changed URLs.

FYI, I've run a search to determine all the articles with problematic
images:

./environment/waste-and-recycling/commercial-waste-collection-service.xml
./environment/policies-reports-and-data/energy.xml
./environment/policies-reports-and-data/agenda-21.xml
./environment/planning-and-built-environment/introduction-to-planning/information-in-other-languages/a-guide-to-the-planning-process.xml
./environment/planning-and-built-environment/conservation-and-design/listed-buildings/camdens-built-heritage.xml
./environment/planning-and-built-environment/conservation-and-design/environmental-enhancement.xml
./environment/planning-and-built-environment/major-developments-in-camden/kings-cross/public-transport.xml
./environment/planning-and-built-environment/major-developments-in-camden/kings-cross/channel-tunnel-rail-link-ctrl.xml
./environment/planning-and-built-environment/major-developments-in-camden/kings-cross/st-pancras.xml
./environment/air-quality-and-pollution/pollutants-of-concern.xml
./environment/air-quality-and-pollution/monitoring-and-modelling.xml
./environment/air-quality-and-pollution/air-quality-data.xml
./transport-and-streets/community-transport-initiatives/in-town-without-my-car-22.xml
./transport-and-streets/parking/payment/parking-meters-and-pay--display-machines.xml
./transport-and-streets/parking/where-to-park/types-of-parking-bays.xml
./transport-and-streets/parking/where-to-park/bloomsbury-square-car-park.xml
./transport-and-streets/parking/clamps-and-removals.xml
./transport-and-streets/traffic-in-camden/congestion-charging.xml
./transport-and-streets/traffic-in-camden/road-safety.xml
./transport-and-streets/transport-strategies/fewer-cars.xml
./transport-and-streets/transport-strategies/car-free-housing.xml
./transport-and-streets/camdens-public-transport/where-is-camden-in-london.xml
./housing/housing-policy-and-strategies/londons-housing-crisis.xml
./community-and-living/your-local-community/cindex-local-information-database.xml
./community-and-living/your-local-community/good-citizen-award-.xml
./z_test_area/Shopmobility_test.xml
./council-and-democracy/plans-and-policies/modernising-government/modernising-government.xml
./council-and-democracy/plans-and-policies/local-strategic-partnership/what-is-the-local-strategic-partnership.xml
./council-and-democracy/who-represents-you/the-mayor-of-camden/the-mayors-role.xml
./council-and-democracy/who-represents-you/the-mayor-of-camden/mayor-of-camden-2003.xml
./council-and-democracy/who-represents-you/the-mayor-of-camden/the-deputy-mayor.xml
./council-and-democracy/who-represents-you/the-mayor-of-camden/the-mayors-office.xml
./council-and-democracy/who-represents-you/camden-and-government/central-government-links.xml
./council-and-democracy/about-the-council/camden-statistics/census-21/census-21---the-first-results.xml
./council-and-democracy/about-the-council/camdens-performance/camdens-cpa-report.xml
./education/pre-school/childrens-information-service/about-the-childrens-information-service.xml
./education/initiatives-and-consultations/schools-air-pollution/transport-and-air-quality.xml
./education/initiatives-and-consultations/schools-air-pollution/particulates.xml
./education/initiatives-and-consultations/schools-air-pollution/nitrogen-dioxide.xml
./education/initiatives-and-consultations/schools-air-pollution/air-pollution-monitoring-in-camden.xml
./education/initiatives-and-consultations/schools-air-pollution/comparison-of-air-pollution-levels-in-camden-with-other-areas-of-the-uk.xml
./education/initiatives-and-consultations/schools-air-pollution/asthma-allergy-and-air-quality.xml
./education/services-for-children-and-parents/camden-lea/what-the-lea-provides.xml
./education/services-for-children-and-parents/camden-lea/vision-and-values.xml
./education/services-for-children-and-parents/camden-lea/main-aims-for-24--29.xml
./education/services-for-children-and-parents/camden-lea/lea-organisational-structure.xml
./education/services-for-children-and-parents/camden-lea-support-services/-european-school-psychologists-for-research-innovation-and-exchange.xml
./micro-business-gateway/mbg_home/find-my-nearest.xml
./business/Film-office/locations.xml
./business/Film-office/immage-test.xml
./business/venues-for-events/camden-centre/event-types.xml
./business/venues-for-events/camden-centre/location.xml
./business/venues-for-events/camden-centre/the-camden-centre.xml
./business/venues-for-events/camden-centre/the-flexible-venue.xml
./leisure/arts-music--culture/cultural-strategy/camdens-cultural-strategy.xml
./leisure/around-camden/map-of-where-camden-is-in-london.xml
./leisure/sports-and-activities/active-health.xml
./leisure/sports-and-activities/sports-development.xml
Comment 3 Daniel Berrange 2004-03-03 14:25:38 EST
Closing because this is not a bug. Including of <img> tags withint
body text is not supported, hence they weren't migrated.
Comment 4 James Kearns 2004-03-27 06:56:17 EST
Your list of all the articles with problematic images has helped a 
lot :) Thanks Dan.


Note You need to log in before you can comment on or make changes to this bug.