Bug 117199 - /ccm/atoz/admin fails when trying to delete an item in the provider list
Summary: /ccm/atoz/admin fails when trying to delete an item in the provider list
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Daniel Berrange
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-01 15:19 UTC by Arturo Dell
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 15:06:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arturo Dell 2004-03-01 15:19:40 UTC
Description of problem: Cannot delete an item in the provider list in
the A to Z application.


How reproducible:Always


Steps to Reproduce:
1. Go to /ccm/atoz/admin/
2. Try to delete an entry in the provider list

  
Actual results:

CCM issue report code: 194.202.210.41:3e7e97b8:fb070553a4

-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code: 194.202.210.41:3e7e97b8:fb070553a4 -*-*-*-
-*-*-*- Message 1: com.caucho.jsp.JspLineException: null (root cause:
null (root cause: ORA-02292: integrity constraint
(APLAWS_PLUS.CAT_ROO_CAT_OBJ_MAP_OB_F_ANFMX) violated - child record found
)) -*-*-*-
-*-*-*- Message 2: com.arsdigita.util.UncheckedWrapperException: null
(root cause: null (root cause: ORA-02292: integrity constraint
(APLAWS_PLUS.CAT_ROO_CAT_OBJ_MAP_OB_F_ANFMX) violated - child record found
)) -*-*-*-
-*-*-*- Message 3: com.arsdigita.persistence.PersistenceException:
null (root cause: ORA-02292: integrity constraint
(APLAWS_PLUS.CAT_ROO_CAT_OBJ_MAP_OB_F_ANFMX) violated - child record found
) -*-*-*-
-*-*-*- Message 4: com.redhat.persistence.engine.rdbms.RDBMSEngine$4:
ORA-02292: integrity constraint
(APLAWS_PLUS.CAT_ROO_CAT_OBJ_MAP_OB_F_ANFMX) violated - child record found
 -*-*-*-

Comment 1 Daniel Berrange 2004-03-02 17:35:44 UTC
Fixed in p4 40962.



Note You need to log in before you can comment on or make changes to this bug.