Bug 117230 - up2date --installall --channel broke
up2date --installall --channel broke
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks: 130798
  Show dependency treegraph
 
Reported: 2004-03-01 15:34 EST by Ken Reilly
Modified: 2009-11-13 11:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-13 11:07:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Graner 2004-03-01 15:34:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The up2date client for Enterprise WS v3 is "4.2.5-1"

Their are no error messages displayed. 

When theup2date command is issued the command prompt returns with no
messages.  The same way it would if you entered an invalid channel
name.  It can't seem to find the channel. I can display all the child
channels with the "up2date --show-channel" command.  

I can also install any RPMs in any child channel if I am explicit with
the name.  Ex.  up2date acroread

All of the production channels are clones. When I try to issue the
"up2date --installall --channel"  command against a live Redhat
channel I have the same problem.  

Version-Release number of selected component (if applicable):
up2date-4.2.5-1

How reproducible:
Always

Steps to Reproduce:
1. Run up2date --installall --channel <clone channel name>
2.
3.
    

Actual Results:  Should install all rpms in the cloned channel. 

Expected Results:  It does not. Prompt just returns with no error
messages.

Additional info:
Comment 1 Adrian Likins 2004-03-02 13:58:05 EST
I don't seem to be having much luck reproducing this. 
Seems to work for me using base channels or childchannels.

investigating
Comment 2 Adrian Likins 2004-03-02 17:01:36 EST
ugh, I see it now. I'll have a fix soon. 
Comment 3 Adrian Likins 2004-03-02 17:20:59 EST
temporary workaround is to do something like:

up2date $(up2date --showall --show-channel | grep CHANNEL-LABEL | perl
-lane 'print $F[0]'|sed -e 's/-[^-]*-[^-]*$//' | uniq)

ugly,but...
Comment 4 Adrian Likins 2004-03-02 17:38:23 EST
btw, this is a dupe of  113973
and is fixed in the 4.2.7 version of the package (not
out yet). 

I completely space and forgot I had already found
and fixed this bug. 
Comment 5 Michael J. Carter 2004-06-24 13:31:27 EDT
Did you mean version 4.2.17??? I'm still having trouble with 4.2.16-1
on RHEL3WS:

[root@rhel3ws-test1 root]# up2date --channel=rhel3-isr-extras --installall
 
Fetching Obsoletes list for channel: rhel-i386-ws-3...
 
Fetching Obsoletes list for channel: rhel3-isr-extras...
 
Fetching Obsoletes list for channel: rhel3-isr-proliant...
 
Fetching obsoletes list for http://yum.isr.lanl.gov/rhel3/proliant...
 
Fetching http://yum.isr.lanl.gov/rhel3/proliant/headers/header.info...
########################################
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1174, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 772, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1066, in batchRun
    batch.run()
  File "up2dateBatch.py", line 60, in run
  File "up2dateBatch.py", line 98, in __findPackagesToUpdate
  File "packageList.py", line 123, in run
  File "rhnPackageInfo.py", line 404, in obsoletesList
  File "rpcServer.py", line 112, in doCall
  File "repoDirector.py", line 27, in getObsoletes
  File "rpmSource.py", line 249, in getObsoletes
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
311, in getObsoletes
    baseFileName = "%s-%s-%s.%s.hdr" % (pkg[0], pkg[1], pkg[2], pkg[4])
IndexError: list index out of range
Comment 7 Red Hat Bugzilla 2007-10-23 11:24:59 EDT
User pgraner@redhat.com's account has been closed

Note You need to log in before you can comment on or make changes to this bug.