Bug 117238 - (TBcc59a44b) redhat-config-network crash caused by * in /etc/hosts / sre.py:229:_compile:error: multiple repeat
redhat-config-network crash caused by * in /etc/hosts / sre.py:229:_compile:e...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks: 86560
  Show dependency treegraph
 
Reported: 2004-03-01 17:03 EST by David Savinkoff
Modified: 2008-01-11 17:20 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.4.7-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:20:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Savinkoff 2004-03-01 17:03:19 EST
A new 'Crashes without saving bug' caused by * in /etc/hosts
Version: redhat-config-network   1.2.15

Steps to Reproduce:
1. Add following line with <tab> as whitespace to /etc/hosts:
192.168.47.47       *.vs.shawcable.ca
2. run redhat-config-network as (su root)
3. make change to setup (optionally change it back for no net change)
4. attempt saving
5. read last few lines of error dump - the error is obvious

Why the asterisk? Well, I have a MS Windows application running with
Wine. This application looks for host * and gives up quickly if it
finds it in /etc/hosts.
Comment 1 David Savinkoff 2004-03-01 17:12:29 EST
Component: redhat-config-network
Version: 1.2.15
Summary: TBcc59a44b sre.py:229:_compile:error: multiple repeat
Traceback (most recent call last):
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 625, in on_applyButton_clicked
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 307, in save
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 339, in saveProfiles
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/NCProfileList.py",
line 326, in save
  File "/usr/lib/python2.2/site-packages/rhpl/Conf.py", line 590, in
__delitem__
    while self.findnextline('^\S*[' + self.separators + ']+' + varname):
  File "/usr/lib/python2.2/site-packages/rhpl/Conf.py", line 199, in
findnextline
    elif re.search(regexp, self.lines[self.line]):
  File "/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py",
line 137, in search
    return _compile(pattern, flags).search(string)
  File "/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py",
line 229, in _compile
    raise error, v # invalid expression
error: multiple repeat

Local variables in innermost frame:
p: None
flags: 0
pattern: ^\S*[	 ]+*.vs.shawcable.net
key: ('^\\S*[\t ]+*.vs.shawcable.net', 0)
v: multiple repeat
Comment 2 andy jones 2005-10-13 15:24:11 EDT
did not work for me:

I am near the end of my patience with this problem!!

since V7 of redhat its existed and i have experienced it ...  a Google for the 
error will back this up ...

I am on RH Enterprise 3 and everytime I use the GUI to change network configs 
it crashes on save .... what the hell is going on??

Component: redhat-config-network
Version: 1.2.63
Summary: TBcc59a44b sre.py:229:_compile:error: multiple repeat
Traceback (most recent call last):
  File "/usr/src/build/439899-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 755, in on_applyButton_clicked
  File "/usr/src/build/439899-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 343, in save
  File "/usr/src/build/439899-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 375, in saveProfiles
  File "/usr/src/build/439899-noarch/install/usr/share/redhat-config-
network/netconfpkg/NCProfileList.py", line 366, in save
  File "/usr/lib/python2.2/site-packages/rhpl/Conf.py", line 571, in __setitem__
    while self.findnextline('^\S*' + '[' + \
  File "/usr/lib/python2.2/site-packages/rhpl/Conf.py", line 199, in 
findnextline
    elif re.search(regexp, self.lines[self.line]):
  File "/usr/src/build/513931-i386/install/usr/lib/python2.2/sre.py", line 137, 
in search
    return _compile(pattern, flags).search(string)
  File "/usr/src/build/513931-i386/install/usr/lib/python2.2/sre.py", line 229, 
in _compile
    raise error, v # invalid expression
error: multiple repeat

Local variables in innermost frame:
p: None
flags: 0
pattern: ^\S*[	 ]+***********ZDNET
key: ('^\\S*[\t ]+***********ZDNET', 0)
v: multiple repeat

I am on version 1.2.63.1 of redhat-config-network ... my host file only has 
this in it:

127.0.0.1 localhost
192.168.113.1 server1 server1.dams.co.za

It used to have *'s (asteriks) in the host file but removing/rebooting/mv'ing 
but no diff since removing/rebooting etc ...btw ... I am on the latest 
subscription level of RHE 3 .. no downloads needed/available from rhn.redhat.com
	# mv /etc/sysconfig/networking /etc/sysconfig/networking.old
and retry to start r-c-network.


above did not work after cleaning out /etc/hosts file

i am trying to get ibm edge working for a client but with this BUG it's 
embarrassing!!
Comment 3 andy jones 2005-10-14 03:14:56 EDT
Problem is sorted ... my error! was the asteriks in the host file!! I cleaned 
it up in /etc but forgot about the copy 
in /etc/sysconfig/networking/profiles/default which still had the original host 
file with asteriks. Once I cleaned that up I could save network settings using 
the gui.

So my conclusion is that asteriks (****) in the host file are the cause of the 
gui network save crash.

we live and we learn. 

Many thanks for your help and support!!!
Comment 4 Fedora Update System 2007-12-06 15:44:44 EST
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'
Comment 5 Fedora Update System 2008-01-11 17:20:20 EST
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.