Bug 117253 - usb.agent[3079]: missing kernel or user mode driver printer
usb.agent[3079]: missing kernel or user mode driver printer
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
high Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Depends On:
  Show dependency treegraph
Reported: 2004-03-02 00:31 EST by Cristian Merz
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-29 16:08:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Cristian Merz 2004-03-02 00:31:11 EST
Description of problem:

When I try to setup my printer (HP DeskJet 3820) with "redhat-config-
printer", the printer is detect perfectly and print the test fine.
I run "lpq" and it show the printer jobs correctly.

But when I reboot my system and run "redhat-config-printer", and run 
the test...the console freeze.

When try to reconnect the printer in the USB the /var/log/messages 
show the next:

ar  2 02:10:16 apolo kernel: usb.c: USB disconnect on device 00:07.2-
1 address 2
Mar  2 02:10:16 apolo kernel: printer.c: usblp0: removed
Mar  2 02:10:17 apolo kernel: hub.c: new USB device 00:07.2-1, 
assigned address 3
Mar  2 02:10:17 apolo kernel: printer.c: usblp0: USB Bidirectional 
printer dev 3 if 0 alt 0 proto 2 vid 0x03F0 pid 0x1904
Mar  2 02:10:18 apolo devlabel: devlabel service started/restarted
Mar  2 02:10:21 apolo usb.agent[3079]: missing kernel or user mode 
driver printer

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

Linux apolo.xmundo.grupoxmundo.com 2.4.22-1.2115.nptl #1 Wed Oct 29 
15:42:51 EST 2003 i686 i686 i386 GNU

I run a fresh fedora core 1 install, when all the rpms originals.
Comment 1 Need Real Name 2004-03-26 15:27:04 EST
I have the same problem too. I use a hp840c. I have tried all related
usb notes related to this message but the problem arise again.
Workaround: reload the driver leads to a successfull printing. (
sometime i need to power off and then on the printer. ) and sometime i
need repeat the procedure more than once.
Comment 2 Pete Zaitcev 2004-08-19 19:04:24 EDT
Forget the message, the printer module is loaded already.

What the heck is "console freeze"?
Comment 3 David Lawrence 2004-09-29 16:08:42 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.