This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 11726 - RH6.2 rsh does not work with RH6.1
RH6.2 rsh does not work with RH6.1
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rsh (Show other bugs)
6.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
: 14306 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-28 22:05 EDT by Ivan Teliatnikov
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-03 14:26:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Teliatnikov 2000-05-28 22:05:44 EDT
Tried to use rsh on RH6.1 to mkdir on client RH6.2. On the client there is
an .rhosts file in /root directory.
in a form of:

server_name.domain_name root
server_name root


When do: rsh clein_host_name mkdir /test I get: Permission deneid.
Comment 1 Pekka Savola 2000-07-15 06:02:16 EDT
Unable to replicate.

Some services require that reverse and forward DNS entries match.  Also, there
might be some relevant info in /var/log/messages.
Comment 2 Pekka Savola 2000-07-15 06:02:56 EDT
Test. please disregard.
Comment 3 Michael 2000-07-19 02:35:17 EDT
I have faced the similar problem: I can not do rsh from RedHat 6.1 to RedHat
6.2.
The name of the client machine (alpha00) is listed in /etc/hosts.equiv on the 
server machine (alpha03).
When I do "rsh alpha03 ls" from alpha00 I get the reply "Permission denied."
The same respond is caused by "rcp file @alpha03:".
When I try "rlogin alpha03" it asks for the password, although it shouldn't.
An interesting detail can be noticed when I do repeated rlogins from alpha00 to
alpha03:
in the string "Last login: ..." the name of the client machine is erroneous: 
"alpah00" instead of "alpha00". The simple workaround was found: I added an
incorrect
name "alpah00" to /etc/hosts.equiv. This caused rsh, rlogin and rcp to work as
expected.

It looks like a bug in the authentication system of RedHat 6.2's
rsh-server-0.16-12, 
since rsh, rlogin, rcp are working well between RedHat 6.1 machines.

Michael.
Comment 4 Bill Nottingham 2000-07-20 15:27:43 EDT
*** Bug 14306 has been marked as a duplicate of this bug. ***
Comment 5 Michael 2000-07-21 19:34:50 EDT
More news about the bug. I have changed the ethernet cards on both computers
from Kingston KNE-110TX to KNE-100TX, and the bug has gone. Michael.

Note You need to log in before you can comment on or make changes to this bug.