Bug 117290 - Raw Hide yum breaks cachedb
Raw Hide yum breaks cachedb
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: yum (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
: 117314 117357 117402 117458 117608 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-02 11:23 EST by Rudi Chiarito
Modified: 2014-01-21 17:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-12 09:05:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rudi Chiarito 2004-03-02 11:23:33 EST
Description of problem:
The Raw Hide yum package from today is broken. Fixed upstream in CVS,
but this should hit everyone with a current system in the meantime.
I'm posting this to avoid a flurry of complaints and duplicates.

Version-Release number of selected component (if applicable):
yum-2.0.5.20040229-1

How reproducible:
Always

Steps to Reproduce:
1. Update yum to 2.0.5.20040229-1
2. Run yum
  
Actual results:Traceback (most recent call last):
  File "/usr/bin/yum", line 30, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 253, in main
    clientStuff.download_headers(HeaderInfo, nulist)
  File "/usr/share/yum/clientStuff.py", line 919, in download_headers
    cachedbdict = returnCacheDBHeaders(nulist)
  File "/usr/share/yum/clientStuff.py", line 901, in returnCacheDBHeaders
    mi = cachedb.dbMatch()


Expected results:
No tracebacks

Additional info:
There is a workaround, courtesy of Seth Vidal. Set usecachedb=0
under [main] in /etc/yum.conf
Comment 1 Rudi Chiarito 2004-03-02 11:46:59 EST
Urgh, the workaround doesn't seem to work for me. I tweaked line 901
to just read

   return {}
Comment 2 Seth Vidal 2004-03-02 12:42:10 EST
apply this diff for a real fix.

This is checked into cvs - it will be in todays daily.
http://devel.linux.duke.edu/cgi-bin/viewcvs.cgi/yum/clientStuff.py.diff?only_with_tag=yum-2_0_X&r1=1.47.2.75.2.20&r2=1.47.2.75.2.21&diff_format=u
thanks for finding this.
Comment 3 Jeff Johnson 2004-03-02 15:31:57 EST
*** Bug 117314 has been marked as a duplicate of this bug. ***
Comment 4 Miloslav Trmac 2004-03-03 06:51:43 EST
*** Bug 117357 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Johnson 2004-03-03 14:39:42 EST
*** Bug 117402 has been marked as a duplicate of this bug. ***
Comment 6 Don Hardaway 2004-03-03 14:56:16 EST
usecachedb=0  does not work for me either.  How do you apply the diff
file mentioned above?
Comment 7 Seth Vidal 2004-03-03 15:01:51 EST
another solution:
download rpmdb-fedora from your development archive and install it

alternatively download the patch to a file: foo.patch


cd /usr/share
patch -p0 < /the/path/to/foo.patch

that's it.
Comment 8 Miloslav Trmac 2004-03-04 09:04:28 EST
*** Bug 117458 has been marked as a duplicate of this bug. ***
Comment 9 Seth Vidal 2004-03-04 20:14:20 EST
If you want a packaged fix.

http://linux.duke.edu/projects/yum/download/2.0/daily/yum-2.0.5-20040303.noarch.rpm

that is going to show up in rawhide in a few days.
Comment 10 Hans Christian Studt 2004-03-05 14:25:39 EST
yum-2.0.5-20040303.noarch.rpm came today and now it WFM again
Comment 11 Miloslav Trmac 2004-03-05 14:25:47 EST
*** Bug 117608 has been marked as a duplicate of this bug. ***
Comment 12 Jeff Johnson 2004-03-12 09:05:42 EST
Fixed afaik.

Note You need to log in before you can comment on or make changes to this bug.