This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 117291 - QT-3.3.1 out but with font problems
QT-3.3.1 out but with font problems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-02 11:52 EST by Sammy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-07 19:03:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen capture showing my font problems (706.13 KB, image/png)
2004-03-03 12:24 EST, Sammy
no flags Details
mexcel3d truetype fonts (101.85 KB, application/octet-stream)
2004-03-03 15:31 EST, Sammy
no flags Details
Patch for fixing a font problem (1.12 KB, patch)
2004-03-04 12:29 EST, Sammy
no flags Details | Diff
New patch for the qt font dropping problem (5.97 KB, patch)
2004-03-16 15:18 EST, Sammy
no flags Details | Diff

  None (edit)
Description Sammy 2004-03-02 11:52:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en) (KHTML, like Gecko)

Description of problem:
As you may no qt-3.3.1 is out. I built the qt-3.3.1 rpm using the
latest qt-3.3.0 source rpm and patches.

The result was that certain fonts were missing/rendered incorrectly.
This happened mainly with certain truetype fonts. Reinstalling
back the 3.3.0 rpms corrected the problem.

FYI

Version-Release number of selected component (if applicable):
qt-3.3.1

How reproducible:
Always

Steps to Reproduce:
1.BUILD 3.3.1 rpm with 3.3.0 patches
2.install and restart kde
3.
    

Additional info:
Comment 1 Sammy 2004-03-02 13:51:01 EST
I just tried the latest qt-3.3.1-0.1 and had the same problem I 
described above. Two things I notice off the top are: 
 
1. I have use the 3D font MEXCEL3D.ttf for the desktop icons 
    and this font goes into the default Verdana instead. 
 
2. The rendering of the ghostscript page looks horrible: 
 
                            http://www.ghostscript.com/ 
 
If I switch back to 3.3.0-0.3 they both work fine. I have even tried  
compiling kde with 3.3.1 and it did not change the problem. 
Comment 2 Sammy 2004-03-03 09:11:35 EST
I again rebuilt the rpm using the latest 3.3.1 snapshot - same problem 
Comment 3 Lars G 2004-03-03 10:30:54 EST
have the same problem with fonts displayed incorrect.
Comment 4 Sammy 2004-03-03 10:33:20 EST
In my case many of the symbol fonts just show an ordinary 
text font! 
Comment 5 Ngo Than 2004-03-03 11:38:16 EST
could you please give me a testcase how i can reproduce this issue.
i don't see this problem here with qt-3.3.1.

It would be great if you could attach the both screenshots? thanks
Comment 6 Sammy 2004-03-03 11:47:47 EST
Can you open the kde control center, choose appearance and fonts, 
use the ...change option to see if you  can see the symbol fonts display 
correctly. I'll reinstall 3.3.1 and try to get screenshots for you in a little 
while. 
Comment 7 Sammy 2004-03-03 12:24:31 EST
Created attachment 98247 [details]
screen capture showing my font problems

Screenshot showing my problems
Comment 8 Sammy 2004-03-03 12:25:13 EST
OK, here is a screen image that shows both problems: 
 
1. With qt-3.3.0 my icon fonts are 3D fonts, here they are some default. 
 
2. With 3.3.0 the ghostscript page reads very nice and clear here it 
    looks like some modern font! 
 
Comment 9 Ngo Than 2004-03-03 12:49:25 EST
it's strange, the symbol fonts are displayed correctly with 3.3.1-0.1
on my local machine.

i also don't see any problem by the rendering of the ghostscript page.
the fonts are displayed correctly!

which version of freetype/XFree88 do you have?
have you installed the rpms from FC2 rawhide?

Does this issue still appears if you only use the default KDE setting
in FC2 (add a new user and login with this new user)?
Comment 10 Sammy 2004-03-03 15:30:02 EST
Yes....I update daily from the development branch. 
 
OK here is more info.... I was rendering Type1 fonts and 
TrueType fonts. I noticed that most Type1 fonts were not 
rendering properly so I removed my Type1 fonts from the 
/etc/fonts/fonts.conf file (always restarting everything and  
caching). Now the ghostscript page shows ok. I had symbol 
and winding fonts as type1, which did not show, but truetype 
ones do show. 
 
The only mystery is that the mexcel3d truetype fonts does not 
show (shows as a regular font). I am going to attach that font 
for you to try. 
 
Bottom line: If you just have Fedora supplied fonts and nothing 
else you would probably notice no difference. But if you have 
more clearly something is not working right BECAUSE I can 
just go back to 3.3.0 rpms and restart and I can see all, 3D, 
type1 etc. 
 
Comment 11 Sammy 2004-03-03 15:31:08 EST
Created attachment 98259 [details]
mexcel3d truetype fonts
Comment 12 Sammy 2004-03-03 15:33:23 EST
OK....a funny thing happened, when I was sending the font 
file through bugzilla and put in the attachement, the preview 
of the fonts showed as large 3D letters (like they are supposed 
to) but in the KDE fonts dialog and desktop they don't. 
Comment 13 Sammy 2004-03-04 08:50:37 EST
This morning I saw readers at: 
 
                    http://dot.kde.org/1078392985/ 
 
complaining about a reintroduction of a font bug. Please see if 
this has any baring on this case or not. 
 
PS: I also filed a bug with qt  people and received a response 
asking some further questions. If I here anything I'll post it here. 
               
Comment 14 Sammy 2004-03-04 12:29:47 EST
Created attachment 98300 [details]
Patch for fixing a font problem

Someone from Trolltech repsonded to the dot.kde.org discussion above and
included a patch.
Comment 15 Sammy 2004-03-04 14:40:41 EST
Bingo.... I have rebuilt qt-3.3.1 with the above patch and fonts are 
back, including the mexcellent3d font.... 
Comment 16 Lars G 2004-03-05 11:02:02 EST
qt-3.3.1-0.3 from todays rawhide fixed it for me too.
thanks sammy and than !
Comment 17 Ngo Than 2004-03-07 19:03:51 EST
yes, it's fixed in qt-3.3.1-0.3. thanks Sammy!
Comment 18 Sammy 2004-03-16 15:18:58 EST
Created attachment 98582 [details]
New patch for the qt font dropping problem

Trolltech sent me a  new patch for the same problem. It seems to be a little
more
extensive than the first one. I used it and it is working fine.
Comment 19 Ngo Than 2004-03-25 14:24:23 EST
oh yes, the new one looks better ;-) it's now included in
qt-3.3.1-0.7. Thanks

Note You need to log in before you can comment on or make changes to this bug.