Bug 117325 - ip.h needs types.h
ip.h needs types.h
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-02 16:00 EST by Bevan Bennett
Modified: 2015-01-04 17:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 20:24:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bevan Bennett 2004-03-02 16:00:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
It looks like /usr/include/linux/ip.h needs an
#include <linux/types.h>
line like most of the other header files have.

Version-Release number of selected component (if applicable):
glibc-kernheaders-2.4-8.36

How reproducible:
Always

Steps to Reproduce:
#include <linux/ip.h>
#include <stdio.h>
 
int main() {
 
  printf("Foo\n");
  return(0);
}

gcc test.c

Actual Results:  In file included from test.c:1:
/usr/include/linux/ip.h:95: error: syntax error before "__u8"
/usr/include/linux/ip.h:102: error: syntax error before "tot_len"
/usr/include/linux/ip.h:103: error: syntax error before "id"
/usr/include/linux/ip.h:104: error: syntax error before "frag_off"
/usr/include/linux/ip.h:105: error: syntax error before "ttl"
/usr/include/linux/ip.h:106: error: syntax error before "protocol"
/usr/include/linux/ip.h:107: error: syntax error before "check"
/usr/include/linux/ip.h:108: error: syntax error before "saddr"
/usr/include/linux/ip.h:109: error: syntax error before "daddr"
Comment 1 Arjan van de Ven 2004-08-03 10:13:40 EDT
fixed for the next build

Note You need to log in before you can comment on or make changes to this bug.