Bug 1173323 - iperf stalls the NetKVM driver
Summary: iperf stalls the NetKVM driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1173034 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-11 21:00 UTC by Yossi Hindin
Modified: 2015-11-24 08:48 UTC (History)
9 users (show)

Fixed In Version: virtio-win-prewhql-0.1-99
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:48:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Yossi Hindin 2014-12-11 21:00:03 UTC
Description of problem: iperf stalls the driver


Version-Release number of selected component (if applicable): Win2008R2, virtio-win b96


How reproducible: Always


Steps to Reproduce:
1. Run Windows 2008R2 inside Qemu with virtio-net device, install NetKVM driver
2. Run iperf on Windows guest as server, "iperf -s"
3. Run iperf client on Linux host with several connections, like "iperf -c <NetKVM IP address> -P 4 -d -t 6000

Actual results: NetKVM driver stop functioning, ping doesn't respond, disable operation stalls


Expected results: Everything should run smoothly


Additional info:

Comment 3 Yossi Hindin 2014-12-14 12:45:26 UTC
Apparently, it is the same problem as reported under 1173034. I am marking the bug as duplicated, the patch is going to be posted today.

Comment 4 Yossi Hindin 2014-12-14 12:49:38 UTC
*** Bug 1173034 has been marked as a duplicate of this bug. ***

Comment 7 lijin 2015-04-07 05:07:42 UTC
can NOT reproduce this issue with build 96

steps:
1.boot a win2k8R2 guest:
2.in guest cmd: #iperf.exe -s
3.on host run iperf client with 10 connections in parallel,such as:
#iperf -c <NetKVM IP address> -P 4 -d -t 6000

on both build 96 and build 102,guest network works fine during/after iperf test

package info:
qemu-kvm-rhev-2.1.2-17.el7.x86_64
kernel-3.10.0-223.el7.x86_64
seabios-1.7.5-8.el7.x86_64

qemu cli:
/usr/libexec/qemu-kvm -name 096RNG2008R2TLK -enable-kvm -m 4G -smp 4 -uuid 73ef2d2b-4b5d-4f3c-90c9-6ef3bb6e3258 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/096RNG2008R2TLK,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=096RNG2008R2TLK,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=096RNG2008R2TLK.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0,queues=4 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:52:47:1e:03:cd,bus=pci.0,addr=0x3,vectors=10 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus

Comment 11 lijin 2015-07-17 07:31:10 UTC
Hi dev,

Could you help to check comment#7,qe cannot reproduce this issue.

Is there any step not correct?

Comment 12 Yan Vugenfirer 2015-07-19 12:58:32 UTC
(In reply to lijin from comment #11)
> Hi dev,
> 
> Could you help to check comment#7,qe cannot reproduce this issue.
> 
> Is there any step not correct?

Will double check. Could be inconsistent reproduction in the first place.

Comment 14 Yan Vugenfirer 2015-09-07 14:29:11 UTC
(In reply to Yan Vugenfirer from comment #12)
> (In reply to lijin from comment #11)
> > Hi dev,
> > 
> > Could you help to check comment#7,qe cannot reproduce this issue.
> > 
> > Is there any step not correct?
> 
> Will double check. Could be inconsistent reproduction in the first place.

Cannot reproduce as well. Build 96 was unstable in any case.

Comment 15 lijin 2015-09-16 02:14:31 UTC
try with virtio-win-prewhql-105,steps same as comment #7,iperf test can finish correctly,guest network still alive.

Based on above ,this issue has been fixed already.

So change status to verified.

Comment 17 errata-xmlrpc 2015-11-24 08:48:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.