Bug 117357 - yum has runtime error when trying to download new headers
yum has runtime error when trying to download new headers
Status: CLOSED DUPLICATE of bug 117290
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-03 02:13 EST by orion
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description orion 2004-03-03 02:13:55 EST
Description of problem: 
 
After my latest update (Feb 2nd) yum has stopped working. 
Typing "yum update" or something similar gets me a UnboundLocalError 
thrown by a bad python statement. 
 
Here's the stack dump: 
 
[root@glamdring root]# yum update 
 
Unable to find pid 
Gathering header information file(s) from server(s) 
Server: Fedora Core 1.90 - Development Tree 
Finding updated packages 
Downloading needed headers 
Traceback (most recent call last): 
  File "/usr/bin/yum", line 30, in ? 
    yummain.main(sys.argv[1:]) 
  File "/usr/share/yum/yummain.py", line 253, in main 
    clientStuff.download_headers(HeaderInfo, nulist) 
  File "/usr/share/yum/clientStuff.py", line 919, in download_headers 
    cachedbdict = returnCacheDBHeaders(nulist) 
  File "/usr/share/yum/clientStuff.py", line 901, in 
returnCacheDBHeaders 
    mi = cachedb.dbMatch() 
UnboundLocalError: local variable 'cachedb' referenced before 
assignment 
[root@glamdring root]# 
 
Version-Release number of selected component (if applicable): 
 
yum-2.0.5.20040229-1 
 
How reproducible: 
 
yum update 
 
Steps to Reproduce: 
1.update to the latest yum package 
2.type "yum update" 
3. 
   
Actual results: 
 
See section #1 
 
Expected results: 
 
I expect it to update my packages or tell me there are none to 
update. 
 
 
 
Additional info:
Comment 1 Daniel Malmgren 2004-03-03 04:12:24 EST
Confirmed. 2.0.5.20040224-2 worked fine, 2.0.5.20040229-1 is a no-go.
Comment 2 Miloslav Trmac 2004-03-03 06:51:41 EST

*** This bug has been marked as a duplicate of 117290 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.