Bug 11736 - RPM seg faults on following command line.
Summary: RPM seg faults on following command line.
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-29 20:50 UTC by Dave Johnson
Modified: 2016-11-10 14:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-26 01:59:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Johnson 2000-05-29 20:50:30 UTC
RPM 3.0.4 seg faults when processing:

 rpm -qlp --queryformat "%{NAME}:\n %{FILENAMES}\n"
/mnt/cdrom/RedHat/RPMS/*.rpm

It does not seg fault on something like:
 rpm -qlp /mnt/cdrom/RedHat/RPMS/*.rpm

Thanks!

Comment 1 Jeff Johnson 2000-06-03 18:25:30 UTC
I need to know what is in /mnt/cdrom in order to reproduce this problem.
What CD is mounted?

Comment 2 Dave Johnson 2000-06-05 16:56:28 UTC
The CD mounted was Red Hat Linux Installation CD #1 from the Deluxe box.

Thanks!

Comment 3 Dmitry V. Levin 2000-06-26 01:59:39 UTC
rpm-3.0.5 (and cvs snapshot) also dumps core
on following command line: "rpm -qp ''".
Dereferencing null appears in lib/misc:749


Comment 4 Jeff Johnson 2001-07-25 20:55:41 UTC
The command
	rpm -qp ""
does not segfault in rpm-4.0.3-0.81.

The other problem is probably due to the use of '*' pulling
in multiple instances of a package.

Comment 5 openshift-github-bot 2016-11-10 14:27:28 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/fc01fb7403795c90315897fa667f92dd44a85f5d
Merge pull request #11810 from jim-minter/issue11736

Merged by openshift-bot


Note You need to log in before you can comment on or make changes to this bug.