Bug 117363 - hfsplus kernel module can't be added
Summary: hfsplus kernel module can't be added
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Stephen Tweedie
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-03 09:34 UTC by Richard Gill
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-03-11 14:47:59 UTC


Attachments (Terms of Use)

Description Richard Gill 2004-03-03 09:34:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.6) Gecko/20040206 Firefox/0.8

Description of problem:
I rebuilt the kernel with fs/hfsplus added as module. 
"make modules" did not succeed: it produced error messages
while compiling the hfsplus code.

I also tried with  fs/hfsplus built-in, 
instead of as a module.
The rebuilding failed at the "make bzImage" stage, 
while busy in the directory
/root/linux-2.4.21-9.0.1.EL/net/xfrm

I append the error messages below.
It did not help to ignore all errors and proceed anyway.
The hfsplus module got built but could not be loaded.

I also tried using the latest hfs and hfsplus code together
with kernel patches from roman at ardistech:
http://www.ardistech.com/hfsplus/
This did change anything.

Also I built and installed some later kernels (2.4.22, 2.4.25)
from kernel.org. This time I succeeded except that the X window
manager would not start, so the system is not much use.

Previously I was able easily to add hfsplus support to Redhat 9.

If anyone is interested I can supply the error messages from
"make modules" when hfsplus support is asked for, as module.

Error messages from "make bzImage" with fs/hfsplus 
support built-in:


In file included from xfrm_algo.c:16:
/root/linux-2.4.21-9.0.1.EL/include/net/ah.h: In function
`ah_hmac_digest':
/root/linux-2.4.21-9.0.1.EL/include/net/ah.h:26: warning: implicit
declaration of function `crypto_hmac_init'
/root/linux-2.4.21-9.0.1.EL/include/net/ah.h:27: `crypto_hmac_update'
undeclared (first use in this function)
/root/linux-2.4.21-9.0.1.EL/include/net/ah.h:27: (Each undeclared
identifier is reported only once
/root/linux-2.4.21-9.0.1.EL/include/net/ah.h:27: for each function it
appears in.)
/root/linux-2.4.21-9.0.1.EL/include/net/ah.h:28: warning: implicit
declaration of function `crypto_hmac_final'
In file included from xfrm_algo.c:19:
/root/linux-2.4.21-9.0.1.EL/include/net/esp.h: In function
`esp_hmac_digest':
/root/linux-2.4.21-9.0.1.EL/include/net/esp.h:49: `crypto_hmac_update'
undeclared (first use in this function)
make[3]: *** [xfrm_algo.o] Error 1
make[3]: Leaving directory `/root/linux-2.4.21-9.0.1.EL/net/xfrm'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/root/linux-2.4.21-9.0.1.EL/net/xfrm'
make[1]: *** [_subdir_xfrm] Error 2
make[1]: Leaving directory `/root/linux-2.4.21-9.0.1.EL/net'
make: *** [_dir_net] Error 2



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.add hfsplus file support (module) to the kernel with (eg) make xconfig
2.make dep; make clean; make bzImage; make modules

    

Actual Results:  Error messages during compilation of hfsplus module.
Not able to add support for hfsplus fs as kernel module.

Expected Results:  I should have been able to add support for hfsplus
filesystems
to the kernel. This is easy to do in redhat linux 9.
I suppose that some of the backporting of 2.6 features is
incompatible with the hfsplus code.

I can well understand that this is not a supported feature of
rh el ws 3 but still it seems to me that it is a bug.


Additional info:

Comment 2 Stephen Tweedie 2004-03-11 14:47:59 UTC
If you can't build the kernel at all, after a "make mrproper", then
that's a bug.  But if it's just the HFS modules, then sorry, for
modules we don't configure in there's simply no support.

Comment 3 Richard Gill 2004-03-11 17:57:21 UTC
Indeed it was just the hfsplus modules (not the hfs modules!)
If you don't want to call it a bug, fine by me. I guess I should
forget RHEL and live on the bleeding edge with Fedora (where I can
mount hfsplus disks, and I don't even need to recompile the kernel
to do it).

Comment 4 Richard Gill 2004-03-11 18:35:51 UTC
PS. the module does compile in 2.4.21; but it doesn't compile 
in rhel modified 2.4.21 kernel. So apparently some changes to the
kernel by redhat are incompatible with this existing module.
I hope you will check that this problem does not persist in
future versions of rhel.

Comment 5 David Lawrence 2004-03-15 18:52:36 UTC
Changing product and version.


Note You need to log in before you can comment on or make changes to this bug.