Bug 117402 - yum complains about pid
yum complains about pid
Status: CLOSED DUPLICATE of bug 117290
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-03 12:08 EST by Don Hardaway
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Hardaway 2004-03-03 12:08:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
For some reason now when i run yum for updates i get this error. Now
sure why? Can't update until i fix this. Help!


[root@localhost root]# yum update
 
Unable to find pid
Gathering header information file(s) from server(s)
Server: Fedora Core 1.90 - Development Tree
Finding updated packages
Downloading needed headers
Traceback (most recent call last):
  File "/usr/bin/yum", line 30, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 253, in main
    clientStuff.download_headers(HeaderInfo, nulist)
  File "/usr/share/yum/clientStuff.py", line 919, in download_headers
    cachedbdict = returnCacheDBHeaders(nulist)
  File "/usr/share/yum/clientStuff.py", line 901, in returnCacheDBHeaders
    mi = cachedb.dbMatch()
UnboundLocalError: local variable 'cachedb' referenced before assignment


Version-Release number of selected component (if applicable):
yum-2.0.5.20040229-1, kernel-2.6.3-1.118

How reproducible:
Always

Steps to Reproduce:
1.type in yum update
2.
3.
    

Actual Results:  [root@localhost root]# yum update
 
Unable to find pid
Gathering header information file(s) from server(s)
Server: Fedora Core 1.90 - Development Tree
Finding updated packages
Downloading needed headers
Traceback (most recent call last):
  File "/usr/bin/yum", line 30, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 253, in main
    clientStuff.download_headers(HeaderInfo, nulist)
  File "/usr/share/yum/clientStuff.py", line 919, in download_headers
    cachedbdict = returnCacheDBHeaders(nulist)
  File "/usr/share/yum/clientStuff.py", line 901, in returnCacheDBHeaders
    mi = cachedb.dbMatch()
UnboundLocalError: local variable 'cachedb' referenced before assignment


Expected Results:  it updates as before

Additional info:
Comment 1 Jeff Johnson 2004-03-03 14:39:39 EST

*** This bug has been marked as a duplicate of 117290 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.