Bug 117410 - yum complains about missing file at first start
yum complains about missing file at first start
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-03 13:19 EST by Ulrich Drepper
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-20 10:55:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2004-03-03 13:19:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040302

Description of problem:
During the first start yum complaint about:

  File "/usr/bin/yum", line 30, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 163, in main
    (log, errorlog, filelog, conf, cmds) = parseCmdArgs(args)
  File "/usr/share/yum/yummain.py", line 87, in parseCmdArgs
    logfd=os.open(conf.logfile, os.O_WRONLY, os.O_APPEND)
OSError: [Errno 2] No such file or directory: '/var/log/yum.log'


After touching /var/log/yum.log it started.

Version-Release number of selected component (if applicable):
yum-2.0.5.20040229-1

How reproducible:
Always

Steps to Reproduce:
1.Remove /var/log/yum.log
2.start yum
3.
    

Actual Results:  prints above error

Expected Results:  starts up

Additional info:
 I think it's just a matter of adding os.O_CREAT to the open line.
Comment 1 Seth Vidal 2004-03-03 14:45:09 EST
Thanks, os.O_CREAT fixed it.

checked into cvs.
Comment 2 Michael Wyraz 2004-03-04 03:27:03 EST
i solved the problem using an (older?) yum:

* download yum-2.0.5-1.noarch.rpm from
http://linux.duke.edu/projects/yum/download.ptml

* save /etc/yum.conf

* install the rpm (using "rpm -uvh yum-2.0.5-1.noarch.rpm --force")

after removing the old yum pidfile it works fine.

I't important to tell yum not to update again to the broken version
(please write a comment if you know how - i dont't ;) )
Comment 3 Michael Wyraz 2004-03-04 03:28:25 EST
i'm sorry. i postet the comment to the wrong yum bug :(
could you remove these two comments?

Note You need to log in before you can comment on or make changes to this bug.