Bug 117414 - Redundant constraint on dnm_granted_context.pd_object_id
Summary: Redundant constraint on dnm_granted_context.pd_object_id
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Aram Kananov
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-03 19:41 UTC by Brett Prucha
Modified: 2007-04-18 17:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-04 18:58:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brett Prucha 2004-03-03 19:41:19 UTC
Description of problem:

Table dnm_granted_context has two constraints on pd_object_id.  SQL 
Server 2000 does not like this.  Also it seems redundant. 
dnm_granted_context.pd_object_id has fk constraint on 
dnm_object_grants.pd_object_id which in turn has a fk constraint on 
dnm_object_1_granted_context.pd_object_id so 
dnm_granted_context.pd_object_id does not need a fk constraint on 
dnm_object_1_granted_context.pd_object_id because it has it 
indirectly through the other constraint.

Comment 1 Aram Kananov 2004-03-04 18:24:28 UTC
Tnx for heads up

fixed in change 41045 


Note You need to log in before you can comment on or make changes to this bug.