Bug 117430 - update syntax in pre-7.3 PostgreSQL scripts
Summary: update syntax in pre-7.3 PostgreSQL scripts
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: other   
(Show other bugs)
Version: nightly
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-03 21:42 UTC by Vadim Nasardinov
Modified: 2007-04-18 17:03 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 18:47:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vadim Nasardinov 2004-03-03 21:42:31 UTC
For consistency, we should probably update

//core-platform/dev/sql/ccm-core/postgres/categorization/trigger-cat_category_category_map.sql
//core-platform/dev/sql/ccm-core/postgres/kernel/trigger-acs_parties.sql

to use the new syntax for triggers introduced in 7.3.  Instead of

  create or replace function parties_group_member_up_fn () returns opaque as '

use 

  create or replace function parties_group_member_up_fn () returns trigger as '

There was a short thread about this on the ccm-engineering-list on
January 16th, but it seems to be missing from the archives:
http://post-office.corp.redhat.com/archives/ccm-engineering-list/2004-January/date.html

The new syntax is already used in

//core-platform/dev/sql/ccm-core/postgres/kernel/triggers-dnm_context.sql
//core-platform/dev/sql/ccm-core/postgres/kernel/triggers-dnm_parties.sql
//core-platform/dev/sql/ccm-core/postgres/kernel/triggers-dnm_privileges.sql

See
http://www.postgresql.org/docs/7.3/static/sql-createtrigger.html
http://www.postgresql.org/docs/7.3/static/sql-createfunction.html

Comment 1 Vadim Nasardinov 2005-08-03 18:47:15 UTC
stale


Note You need to log in before you can comment on or make changes to this bug.