Bug 1174336 - builddep error output is useless
Summary: builddep error output is useless
Keywords:
Status: CLOSED DUPLICATE of bug 1155211
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-12-15 16:30 UTC by Vít Ondruch
Modified: 2015-01-05 11:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-05 11:27:00 UTC


Attachments (Terms of Use)

Description Vít Ondruch 2014-12-15 16:30:15 UTC
Description of problem:
dnf builddep --installroot /var/lib/mock/ruby22-rhel-7/root/ --releasever 7 /var/lib/mock/ruby22-rhel-7/root//builddir/build/SRPMS/ruby22-ruby-2.2.0-0.24.r48741.el7.src.rpm
Package scl-utils-build-20130529-9.el7_0.x86_64 is already installed, skipping.
Package ruby22-runtime-2.0-1.el7.x86_64 is already installed, skipping.
Error: no package matched


vs


yum-builddep --installroot /var/lib/mock/ruby22-rhel-7/root/ --releasever 7 /var/lib/mock/ruby22-rhel-7/root//builddir/build/SRPMS/ruby22-ruby-2.2.0-0.24.r48741.el7.src.rpm
Getting requirements for ruby22-ruby-2.2.0-0.24.r48741.el7.src
 --> Already installed : scl-utils-build-20130529-9.el7_0.x86_64
 --> Already installed : ruby22-runtime-2.0-1.el7.x86_64
 --> autoconf-2.69-11.el7.noarch
 --> gdbm-devel-1.10-8.el7.x86_64
 --> libffi-devel-3.0.13-11.el7.x86_64
 --> 1:openssl-devel-1.0.1e-40.el7.x86_64
 --> libyaml-devel-0.1.4-10.el7.x86_64
 --> readline-devel-6.2-9.el7.x86_64
 --> 1:tk-devel-8.5.13-4.el7.x86_64
 --> procps-ng-3.3.9-6.el7.x86_64
 --> systemtap-sdt-devel-2.6-7.el7.x86_64
Error: No Package found for db4-devel


Version-Release number of selected component (if applicable):
$ rpm -q dnf
dnf-0.6.2-1.fc21.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
The information what is actually wrong is not provided.

Expected results:
Error which package is missing is provided.

Additional info:

Comment 1 Miroslav Suchý 2015-01-05 11:27:00 UTC

*** This bug has been marked as a duplicate of bug 1155211 ***


Note You need to log in before you can comment on or make changes to this bug.