Bug 11759 - linuxconf crash
linuxconf crash
Status: CLOSED DUPLICATE of bug 11073
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-30 10:35 EDT by mal
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 10:35:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mal 2000-05-30 10:35:56 EDT
linuxconf crashed.
It was started as linuxconf --text
(otherwise with Gnome frontend it crashes so often that it is almost
useless)
and during editing ppp accounts it crashes.
The trace is below:

 gdb linuxconf core
GNU gdb 19991004
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
Core was generated by `linuxconf --text'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libm.so.6...done.
Reading symbols from /usr/lib/libncurses.so.4...done.
Reading symbols from /lib/libdl.so.2...done.
Reading symbols from /lib/libcrypt.so.1...done.
Reading symbols from /usr/lib/libgd.so.1...done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/ld-linux.so.2...done.
Reading symbols from /usr/lib/linuxconf/redhat/redhat.so.1.17.2...done.
Reading symbols from /lib/libpam.so.0...done.
Reading symbols from /usr/lib/linuxconf/modules/apache.so.1.17.2...done.
Reading symbols from /usr/lib/linuxconf/modules/dnsconf.so.1.17.2...done.
Reading symbols from /usr/lib/linuxconf/modules/inetdconf.so.1.17.2...done.
Reading symbols from /usr/lib/linuxconf/modules/inittab.so.1.17.2...done.
---Type <return> to continue, or q <return> to quit---
Reading symbols from /usr/lib/linuxconf/modules/modemconf.so.1.17.2...done.
Reading symbols from /usr/lib/linuxconf/modules/motd.so.1.17.2...done.
Reading symbols from /usr/lib/linuxconf/modules/redhatppp.so.1.17.2...done.
Reading symbols from /usr/lib/linuxconf/modules/samba.so.1.17.2...done.
Reading symbols from /usr/lib/linuxconf/modules/treemenu.so.1.17.2...done.
Reading symbols from /lib/libnss_files.so.2...done.
Reading symbols from /usr/lib/linuxconf/modules/pppdialin.so.1.17.2...done.
#0  0x80c8606 in DIALOG::editterm ()
(gdb) bt
#0  0x80c8606 in DIALOG::editterm ()
#1  0x80c4688 in DIALOG::edit ()
#2  0x80c22cf in DIALOG::editmenu ()
#3  0x80c0fbd in DIALOG_RECORDS::editmenu ()
#4  0x80a5d2d in USERS::select_sorted ()
#5  0x80a5dd6 in USERS::select ()
#6  0x80a68d9 in USERS::edit ()
#7  0x80a6a6f in users_edit ()
#8  0x80a43e4 in userconf_edit ()
#9  0x807062e in linuxconf_editctrl ()
#10 0x80cb303 in uithread ()
#11 0x8070989 in linuxconf_mainmenu ()
#12 0x8070a66 in linuxconf_main ()
#13 0x402c1b7f in treemenu_jump ()
   from /usr/lib/linuxconf/modules/treemenu.so.1.17.2
#14 0x402c2980 in treemenu_maintext ()
   from /usr/lib/linuxconf/modules/treemenu.so.1.17.2
#15 0x402c2bbd in treemenu_main ()
   from /usr/lib/linuxconf/modules/treemenu.so.1.17.2
#16 0x402c2cbe in MODULE_treemenu::message ()
   from /usr/lib/linuxconf/modules/treemenu.so.1.17.2
#17 0x80b46aa in module_sendmessage ()
#18 0x8070a52 in linuxconf_main ()
---Type <return> to continue, or q <return> to quit---
#19 0x806f025 in main ()
#20 0x400f99cb in __libc_start_main (main=0x806e40c <main>, argc=2,
    argv=0xbffffb44, init=0x806d520 <_init>, fini=0x80d20a0 <_fini>,
    rtld_fini=0x4000ae60 <_dl_fini>, stack_end=0xbffffb3c)
    at ../sysdeps/generic/libc-start.c:92
(gdb)
Comment 1 Trond Eivind Glomsrxd 2000-09-13 18:51:08 EDT

*** This bug has been marked as a duplicate of 11073 ***

Note You need to log in before you can comment on or make changes to this bug.