Bug 11762 - (FIX INCLUDED) /etc/rc.d/init.d/functions misbehaves
Summary: (FIX INCLUDED) /etc/rc.d/init.d/functions misbehaves
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: basesystem (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-30 15:49 UTC by ph0n1c
Modified: 2014-03-17 02:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 15:49:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ph0n1c 2000-05-30 15:49:38 UTC
"killproc" in /etc/rc.d/init.d/functions fails to stop some daemons.

Instead of:(line 98)------------------------------------------------

# Save basename.
base=`basename $1`

# Find pid.
pid=`pidofproc $base`

It should be:------------------------------------------------

# Save basename.
base=`basename $1`

# Find pid.
pid=`pidofproc $1`


Since "pidofproc" does its own "basename" if necessary.

Comment 1 Bill Nottingham 2000-05-31 21:43:33 UTC
should be fixed in initscripts-5.14-1.
(Please try and report bugs against the proper components - thanks!)


Note You need to log in before you can comment on or make changes to this bug.