Bug 117649 - install on external USB harddisk is not quite there
install on external USB harddisk is not quite there
Status: CLOSED DUPLICATE of bug 117650
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-06 02:41 EST by Paul Ionescu
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Ionescu 2004-03-06 02:41:03 EST
Description of problem:
I have an IBM T40 thinkpad and an external 20G USB2 harddrive.
I want to install and boot FC2 test1 on this USB harddrive.
For this, I select "expert" mode at the beginnig of instalation,
otherwise the USB hard is not available for install.
After that, everything is installing fine, except that the created
initrd image for booting the system does not contain the drivers for 
USB+scsi and thus is not detecting the root harddrive.
Moreover, I requested that GRUB should be installed on /dev/sda and
not the default /dev/hda, but it didn't install on /dev/sda.
After install went OK, I could not boot the system because of the
forementioned issues. I managed to boot the old linux from my internal
hard, and did some tricks to boot the new FC2test1 from usb.
The tricks were:
Create a initrd image with drivers for USB+some scsi+usb_storage, boot
 the FC2 test1, do an grub-install by hand, and that was it.
Now I can boot FC2 from my external USB2 harddrive.



Version-Release number of selected component (if applicable):
Fedora Core 2 test1

How reproducible:
Always

Steps to Reproduce:
1.install FC2 on usb2 harddrive
2. try to boot from that drive
3. 
  
Actual results:
it doesn't boot

Expected results:
shoult boot OK, and insert the usb stuff for finding the usb disk.
this should not be so hard to fix because I think it already does this
for scsi discs. It just have to know that USB disks are like scsi
disks and they need kernel modules x,y.

Additional info:
willing to test new anacondas for usb2 install
Comment 1 Paul Ionescu 2004-03-06 02:51:12 EST

*** This bug has been marked as a duplicate of 117650 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:51 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.